Jetson Orin NX 16GB Camera support (Arducam IMX519)

I am using arducam IMX519 with jetson orin nx 16gb JP5.1.1 . However I am having problems with this camera module.


I have used the same camera module in Jetson nano and it was working fine.

Right now, I am using Jetson Orin NX 16GB with nvidia jetpack 5.1.1. I installed it using this guide (JetPack-5.1.1 Installation for DSBOARD-ORNX). When I connect the camera on camport1 using 15pin flex cable or on camport 0 using 22pin flex cable. The output of the command nvgstcapture-1.0 is

Encoder null, cannot set bitrate!
Encoder Profile = High
Supported resolutions in case of ARGUS Camera
  (2) : 640x480
  (3) : 1280x720
  (4) : 1920x1080
  (5) : 2104x1560
  (6) : 2592x1944
  (7) : 2616x1472
  (8) : 3840x2160
  (9) : 3896x2192
  (10): 4208x3120
  (11): 5632x3168
  (12): 5632x4224

Runtime ARGUS Camera Commands:

  Help : 'h'
  Quit : 'q'
  Set Capture Mode:
          (1): image
          (2): video
  Get Capture Mode:
  Set sensor orientation:
          (0): none
          (1): Rotate counter-clockwise 90 degrees
          (2): Rotate 180 degrees
          (3): Rotate clockwise 90 degrees
  Get sensor orientation:
  Set sensor mode:
      smo:<val> e.g., smo:1
  Get sensor mode:
  Set Whitebalance Mode:
          (0): off
          (1): auto
          (2): incandescent
          (3): fluorescent
          (4): warm-fluorescent
          (5): daylight
          (6): cloudy-daylight
          (7): twilight
          (8): shade
          (9): manual
  Get Whitebalance Mode:
  Set Saturation (0 to 2):
      st:<val> e.g., st:1.25
  Get Saturation:
  Set Exposure Compensation (-2 to 2):
      ec:<val> e.g., ec:-2
  Get Exposure Compensation:
  Set Auto Whitebalance Lock:
      awbl:<val> e.g., awbl:0
  Get Auto Whitebalance Lock:
  Set Auto Exposure Lock:
      ael:<val> e.g., ael:0
  Get Auto Exposure Lock:
  Set TNR Mode:
      tnrm:<val> e.g., tnrm:1
          (0): OFF
          (1): FAST
          (2): HIGH QUALITY
  Get TNR Mode:
  Set TNR Strength (-1 to 1):
      tnrs:<val> e.g., tnrs:0.5
  Get TNR Strength:
  Set EE Mode:
      eem:<val> e.g., eem:1
          (0): OFF
          (1): FAST
          (2): HIGH QUALITY
  Get EE Mode:
  Set EE Strength (-1 to 1):
      ees:<val> e.g., ees:0.5
  Get EE Strength:
  Set Auto Exposure Anti-Banding (0 to 3):
      aeab:<val> e.g., aeab:2
          (0): OFF
          (1): MODE AUTO
          (2): MODE 50HZ
          (3): MODE 60HZ
  Get Auto Exposure Anti-Banding:
  Set Gain Range:
      gr:<val><space><val> e.g., gr:1 16
  Get Gain Range:
  Set Exposure Time Range:
      etr:<val><space><val> e.g., etr:34000 35000
  Get Exposure Time Range:
  Set ISP Digital Gain Range:
      dgr:<val><space><val> e.g., dgr:2 152
  Get ISP Digital Gain Range:
  Capture: enter 'j' OR
           followed by a timer (e.g., jx5000, capture after 5 seconds) OR
           followed by multishot count (e.g., j:6, capture 6 images)
           timer/multihot values are optional, capture defaults to single shot with timer=0s
  Start Recording : enter '1'
  Stop Recording  : enter '0'
  Video snapshot  : enter '2' (While recording video)
  Get Preview Resolution:
  Get Image Capture Resolution:
  Get Video Capture Resolution:

Runtime encoder configuration options:

  Set Encoding Bit-rate(in bytes):
      br:<val> e.g., br:4000000
  Get Encoding Bit-rate(in bytes):
  Set Encoding Profile(only for H.264):
      ep:<val> e.g., ep:1
          (0): Baseline
          (1): Main
          (2): High
  Get Encoding Profile(only for H.264):
  Force IDR Frame on video Encoder(only for H.264):
      Enter 'f'

bitrate = 4000000
Encoder Profile = High
Encoder control-rate = 1

Using winsys: x11
** Message: 17:02:58.433: <main:4734> iterating capture loop ....
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:751 No cameras available
NvMMLiteOpen : Block : BlockType = 4
===== NVMEDIA: NVENC =====
NvMMLiteBlockCreate : Block : BlockType = 4
ERROR on bus: by /GstPipeline:capture_native_pipeline: Output window was closed
debug info:
/dvs/git/dirty/git-master_linux/tests-multimedia/nvgstapps/nvgstcapture-1.0/nvgstcapture.c(4159): nvgst_handle_xevents (): /GstPipeline:capture_native_pipeline

And when I am trying to install arducam driver from this guide (Quick Start Guide - Arducam Wiki)

The output of the command ./ -m arducam is

./ line 241: warning: command substitution: ignored null byte in input
--2023-08-01 16:39:48--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: [following]
--2023-08-01 16:39:48--
Resolving (,,, ...
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10202 (10.0K) [application/octet-stream]
Saving to: ‘arducam_links.txt’

arducam_links.txt   100%[===================>]   9.96K  --.-KB/s    in 0.001s  

2023-08-01 16:39:49 (8.91 MB/s) - ‘arducam_links.txt’ saved [10202/10202]

--2023-08-01 16:39:49--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: [following]
--2023-08-01 16:39:49--
Resolving (,,, ...
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 9966386 (9.5M) [application/octet-stream]
Saving to: ‘arducam-nvidia-l4t-kernel-t234-nx-5.10.104-tegra-35.3.1-20230725012901_arm64.deb’

arducam-nvidia-l4t- 100%[===================>]   9.50M  9.30MB/s    in 1.0s    

2023-08-01 16:39:50 (9.30 MB/s) - ‘arducam-nvidia-l4t-kernel-t234-nx-5.10.104-tegra-35.3.1-20230725012901_arm64.deb’ saved [9966386/9966386]

[sudo] password for nvidia:
(Reading database ... 171443 files and directories currently installed.)
Preparing to unpack arducam-nvidia-l4t-kernel-t234-nx-5.10.104-tegra-35.3.1-20230725012901_arm64.deb ...
Unpacking arducam-nvidia-l4t-kernel (5.10.104-tegra-35.3.1-20230725012901) over (5.10.104-tegra-35.3.1-20230725012901) ...
Setting up arducam-nvidia-l4t-kernel (5.10.104-tegra-35.3.1-20230725012901) ...

Traceback (most recent call last):
  File "/opt/arducam/jetson-io/", line 125, in <module>
  File "/opt/arducam/jetson-io/", line 94, in main
    jetson = board.Board()
  File "/opt/arducam/jetson-io/Jetson/", line 230, in __init__
    self.dtb = _board_get_dtb(self.compat, self.model, dtbdir)
  File "/opt/arducam/jetson-io/Jetson/", line 114, in _board_get_dtb
    raise RuntimeError("No DTB found for %s!" % model)
RuntimeError: No DTB found for Orin NX 16GB for DSBOARD-ORNXLAN!
An unknown error occurred while installing dtoverlays.
dpkg: error processing package arducam-nvidia-l4t-kernel (--install):
 installed arducam-nvidia-l4t-kernel package post-installation script subprocess returned error exit status 255
Errors were encountered while processing:

I have gone through many thread and try out many solutions but nothing worked for me so far.

hello deepak.bamania,

it looks the installation has failed. please check with sensor vendor to confirm that’s supported on Orin NX.
BTW, are you using Orin NX DevKit (p3768+p3767), or, it’s Orin NX on Xavier NX carrier board (p3509+p3767)?

Hey @JerryChang ,
Thanks for your reply, according to this link this sensor is supported on Orin NX Jetson Partner Supported Cameras | NVIDIA Developer
And I am using Orin NX p3509+p3767

hello deepak.bamania,

you may also contact with sensor vendor since there’s installation failure.

@JerryChang Yes, I am also in contact with arducam. I am using Forecr Jetson Orin NX and it seems like they don’t support the 3rd party boards yet

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.