Jetson Orin NX 8GB does not boot to uefi

Product referred in this post: Jetson Orin NX 8GB (not working), Jetson Orin NX 16GB (Working fine, used for debug purpose)
Carrier Board: custom carrier board.
Host Machine OS: Ubuntu 22.04

Issue occurred:
after multiple failed flash in sdk manager to the Jetson Orin NX 8GB. One of the failed flash log is attached. (not the one right before it does not boot to UEFI)

Debug Attempt:

  • I tested the carrier board with a Jetson Orin NX 16GB, and it successfully boot into OS.
  • I used the same carrier board with the working NX 16GB. It can enter force recovery mode, indicating by the fact that I can lsusb on host machine, and it shows the board. SDK manager is also able to recognize the working 16GB board.
  • The non-working 8GB board is not detected using lsusb by host machine after entering force recovery mode by press recovery and reset, then release reset, and release recovery, on the same board
  • The non-working 8GB board does not boot into UEFI after powered on.

Analysis:
Corrupted bootloader or similar issue? If it is indeed this issue, any hints on how to do a reflash for the “bootloader”?

Any help would be appreciated.

SDKM_logs_JetPack_6.0_DP_Linux_for_Jetson_Orin_NX_modules_2024-04-24_19-20-57.zip (270.2 KB)

Hi jiaxiejason,

What’s your Jetpack version in use? It seems JP6.0DP (R36.2)!?

Since you are using the custom carrier board, SDKM should not work.
Please get the custom BSP package from your vendor and use initrd flash script to flash your board.
Or do you have the Orin Nano devkit(p3768) board to verify?

Could you share the serial console log when you hit boot issue with Orin NX 8GB?

Hi Keven,

Thanks for the fast reply.

To clarify, I had successfully flashed the Orin 8GB using SDKM (it boots into OS). Then I tried to flash again using SDK manager, the issue occurs after multiple failed “re-flashing” attempts.

To answer the questions:

  1. Jetpack version 6.0?
    The captured log is the attemp when I tried to flash jetpack 6.0 DP onto the board. I also tried to flash 5.1.1 and 5.1.2 on a ubuntu 20.04 host machine.

  2. SDK manager for custom carrier board

I understand I am not supposed to use SDK manager to flash since device tree are other hardware-relative parameters might not match. However, the vendor guide me to flash using SDKM and modify device tree afterwards, which works fine for me before.

  1. Orin Nano devkit(p3768) board to verify?
    I do not have a Orin Nano devkit to verify. I do have a Connect Tech Boson-22 Carrier Board for NVIDIA® Jetson Orin™ NX.
    – Orin NX 16 GB works with this carrier board: I put orin nx 16 GB into force recovery, and the host machine recognized this board
    – Orin NX 8GB doe NOT work: I put orin nx 8GB into force recovery, and the host machine doe not recognize this board

  2. Console Log
    I am still working on soldering uart cables as both the custom carrier board and connect tech board requires some soldering. I will get back to you for this console log. Before that any other suggestions on how to debug?

Thanks for your time and petience

We would suggest you checking with your board vendor for the release on their custom board.
The board is not designed by you so that you don’t need to port them by yourself.

It should depend on if you can boot up the board successfully or you can not modify the device tree.

Do you have the flash log when you try to flash Orin NX 8GB?

We would need to check the serial console log or we don’t know what’s the happening.