Jetson Orin NX massflash not working

I am trying to mass flash multiple jetson orin nx on my aaeon carrier board.

I have created the flash image successfully following workflow 2 (online mode with jetson orin nx connected in recovery mode)

sudo ./tools/kernel_flash/ --external-device sda1 -S 56GiB --no-flash --massflash 4   -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" --showlogs --network usb0 jetson-orin-nano-devkit internal

then flash 4 connected devices using:

sudo ./tools/kernel_flash/ --flash-only  --massflash 4  --showlogs

I get this error:

[   0.0752 ] rcm boot with presigned binaries
[   0.0773 ] tegrarcm_v2 --instance 1-2 --new_session --chip 0x23 0 --uid --download bct_br br_bct_BR.bct --download mb1 mb1_t234_prod_aligned_sigheader.bin.encrypt --download psc_bl1 psc_bl1_t234_prod_aligned_sigheader.bin.encrypt --download bct_mb1 mb1_bct_MB1_sigheader.bct.encrypt
[   0.0793 ] BR_CID: 0x80012344705DD20D6C00000004FE8280
[   0.0884 ] Sending bct_br
[   0.0960 ] Sending mb1
[   0.0966 ] Sending psc_bl1
[   0.1102 ] Sending bct_mb1
[   0.1183 ] Generating blob for T23x
Error: invalid format kernel
Cleaning up...

But when i run this:

sudo ./tools/kernel_flash/ --flash-only  --massflash 1  --showlogs

the flash works. but i defeats the purpose of doing massflash if only 1 device can be flashed at a time.

I have modifed my kernel to have a built in driver support for my sata device.

any help will be greately appreciated!!


Can you please show the full flashing log and serial console log under both circumstances?
Have you checked if each of the 4 devices can be flashed with --massflash 1?
Or it only happens on specific devices?

Hi DaveYYY,

Thank you for the help. there was a hardware issue on my side where some of the usb drives I bought were faulty.
reflashing with verified USB drives worked when running with --massflash 2

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.