Jetson orin suddenly gets stuck at login screen

i am working with a jetson orin NX, jetpack 5.1, it had worked well for a few days with coding, browsing, using cuda/GPU all had been good

suddenly when i power it on a new day, it booted well until the login screen, i entered the password, the screen got black in a sec, then the login screen is back again. This is an endless loop, i cannot access the desktop anymore
the password is correct as if i enter wrong password, it will report wrong password and not jumps into black screen in a sec.
i saw a couples of suggestion about nvidia driver but cannot access terminal by ctrl+alt+fn
would appreciate any help

It should be accessible in one or all of these methods:

  • ssh
  • Serial console.
  • CTRL-ALT-F3 (several of the β€œCTRL-ALT-F#” go to consoles, and usually the β€œALT-F1” key binding goes back to the GUI).

After one attempt to access the GUI (and otherwise a fresh boot), attach a copy of the β€œ/var/log/Xorg.0.log” file. Probably also a copy of either β€œdmesg” or the full serial console boot log.

1 Like

thank for the reply
ssh is not available as i am not sure if it is activated (and now i can’t access the terminal to do so), i also dont know the IP (again, must access terminal to know)
i tried ctrl-alt+all fn, they all behave alike, a black screen and i had to hold power button turn it off
what is serial console? how can i use it?

If you have another monitor of a different model, it might be worth giving it a try… Black consoles may be resulting from an misunderstood EDID sent by your monitor.

Serial console is a serial link, such as UART or available from usb-serial depending on your platform. If using AGX Orin devkit, then you would connect micro-USB port of AGX devkit to host where you would use a terminal supporting serial interface such as minicom or gtk-term on Linux, or puTTY on Windows. You would configure host terminal with the correct USB port number, and set framing speed 115200 , 8 data bits, N (no) parity, 1 stopbit.
If your Jetson is set to output boot logs and interact with serial console (default), when powering it on you should see the various stages, finally Linux boot and then you should see a login prompt. If your user/password pair is correct, you would be able to get a working shell.

One possible cause of your issue is if you removed your user from video group.

nvidia adm cdrom sudo audio dip video plugdev render i2c lpadmin gdm sambashare weston-launch gpio
1 Like

another monitor does not work, however the serial terminal works

but all the command I typed on the host return " bash command not found", even sudo or apt-update or ls return command not found!!
how should i move on

i fixed the issue, i changed the PATH (environment variable) to bin folder of an external library to make it work so it does not point at /usr/bin , therefore all the problems (sign-in and command) come!!!

thank @Honey_Patouceul for the instruction of serial log, it is the pure gold here

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.