Jetson SDK components install problem

Dear all,

I am trying to use Jetson Xavier. I installed host components and flashed jetson OS with no problem.
But when It comes to target components install, STATUS is in ‘pending install’ and no longer in progress.

Any ideas?

ping test between host and target is ok.

BTW, Which network is used for the target components install?
Is it ip-over-usb network? I saw l4tbr0 interface from target.


I’m not sure what changes are in place for SDK Manager (I won’t be able to get to it till this weekend), but JetPack is the intermediate software. Somewhere during the install it should ask which method to use, e.g., ethernet over USB, direct ethernet with host as router, or to a router appliance. This is what picks the method.

The presence of the ip-over-usb is in part coincidental as an example of setting up Linux “gadget” mode USB. Regardless of the interface, should you give it the IP address, and if from your host you can connect via “ssh nvidia@”, then it will work. The various options determine whether the host itself will be altered to act as a router or not…the actual communications will be the same once the Xavier has an IP address.

FYI, you can skip flash and run package install at any time, but you’ll probably need to manually enter the IP address when doing so.

You seems to mention old installation process before introducing sdkmanager.
There was no asking which method to use.

BTW, I removed .nvsdkm and config/sdkmanager and retried the installation.
I successfully installed the jetson SDK components. It seems to be OK
because I can execute visionworks sample.

I am wondering when the stable version of sdkmanager will be released.


SDKManager uses ip-over-usb network. Do you have the log files in ~/.nvsdkm directory when target components installation hangs?

YEP. There was a sdkm.log file in this folder.

Just a general tip…when packages fail install often it seems to be because the host did not see the virtual ethernet on the USB cable. Basically if you unplug and replug the cable, look at the MAC address in the dmesg output, and then tell your host’s network config tool to use that MAC, then this will probably be enough to continue the install.

I tried another new flash with another username (but the same password) and through another usb, and it installed.
(Previously I had tried with the same username and password, even tried to delete the ssh chache and sdkmanager never could pass the true login and password of xavier. I had a previous installation with the same username and maybe it created a conflict…)