Jetson SDK Components installation problem

Hi all,

I have following problem: I’ve successfully flashed OS on my Jetson TX2 target hardware. Then I’ve gone through the Ubuntu setup on my TX2 HW and created new account (There a space in the username, I don’t know if it is relevant, but prefer to mention). TX2 is booting successfully and I and OS works fine, but I cannot install any of SDK components. SDK manager permanently try to connect with Jetson devkit. I’ve checked via ‘lsusb’ if there is any Nvidia equipment detected and there is, so it looks fine. I’ve also tried to use ethernet cable and use eth0 IP of my dev board. In first case (via micro-USB) there is permanent connect on the SDK manager side on my host PC. In the second case (via ethernet cable and eth0 IP) SDKM shows: ‘Cannot conect via SSH’.

Thanks for any hints or tips.


Note that the Jetson should not be in recovery mode if adding packages (recovery mode is used during flash, but then the Jetson reboots before adding extra packages). Also, in more recent releases you need a monitor and keyboard connected to the Jetson for first boot of the Jetson…you need to add an account/password. If you can ping an address, but not ssh in, then this is consistent with lacking an account.


Thanks for answer. Unfortunately it doesn’t solve my problem. I’ve created account/password on the Jetson side. Jetson definitely is not in recovery mode. I can’t ping the IP, I checked it on Jetson side na tried to connect via the IP. It seems ethernet connection doesn’t work at all and USB connection doesn’t work correctly. Device is visible but I cannot conect to it to install any packages. :(.

Are you able to use ssh to that account at address Example, “ssh someone@”. I assume not if you can’t ping.

It is also possible your host was set to ignore this device until you allow it to activate (host side configuration). On the host PC, what do you from the commands “route” and “ifconfig” when the micro-B USB cable connects to the host PC (and the Jetson is fully booted)?

Tip: Ubuntu has a network setup icon near the upper right of the desktop. You might need to run “dmesg --follow”, and monitor for MAC address as you plug in the micro-B USB to the host PC. This tool identifies interfaces via MAC.