Jetson TK1 and Blender

Blender 3D modeling software refuses to launch. A grey window briefly appears and then closes. Are there other prerequisites to installing this? GIMP and VLC installed fine. I’ve tried installing from the Ubuntu software center and terminal. And with the source tarball there is no configure file.

Audacity isn’t working as well. I tried to compile but get a warning about missing wx-config

Hello Yakov,
Nice that we got another software tester here :-)

  • Please add non working applicatioons to the following message thread:

https://devtalk.nvidia.com/default/topic/753099/jetson-tk1-ubuntu-14-04-non-working-packages-and-applications-/

  • Please try starting applications form the Command Line if they do not work, this will give you
    more informations what could be wrong.

-If you start blender from the CLI you get this info:

ubuntu@tegra-ubuntu:~ blender Color management: using fallback mode for management connect failed: No such file or directory Writing: /tmp/blender.crash.txt Segmentation fault ubuntu@tegra-ubuntu:~ cat /tmp/blender.crash.txt

Blender 2.69 (sub 0), Revision: unknown

backtrace

-If you start blender via strace you get this info:
strace -e open blender

open("/dev/urandom", O_RDONLY|O_LARGEFILE|O_CLOEXEC) = 16
— SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x54} —

Is there a problem with the urandom device ?

Sure, I’ll put non-working applications in that thread. I just added a reply for Wolfram Mathematica.

hi,
i’m experiencing the same problem with blender. i’m surprised that it is now 17 months later and no improvements.

I just tried blender, had the same results. However, I think urandom is the last successful event, rather than the failed event. A return of “-1” would be fail. To test, you can use “cat /dev/urandom” (possibly pipe the output to “strings”), and the device urandom works.

I installed package blender-dbg, and ran under gdb. Here is the backtrace:

Program received signal SIGSEGV, Segmentation fault.
0xb6c5323e in PyErr_SetObject () from /usr/lib/arm-linux-gnueabihf/libpython3.4m.so.1.0
(gdb) bt
#0  0xb6c5323e in PyErr_SetObject () from /usr/lib/arm-linux-gnueabihf/libpython3.4m.so.1.0
#1  0xb6c533b4 in PyErr_Format () from /usr/lib/arm-linux-gnueabihf/libpython3.4m.so.1.0
#2  0xb6c5161c in PyType_Ready () from /usr/lib/arm-linux-gnueabihf/libpython3.4m.so.1.0
#3  0xb6c30768 in _PyExc_Init () from /usr/lib/arm-linux-gnueabihf/libpython3.4m.so.1.0
#4  0xb6ca0e40 in _Py_InitializeEx_Private () from /usr/lib/arm-linux-gnueabihf/libpython3.4m.so.1.0
#5  0x00661f5c in BPY_python_start (argc=1, argv=0xbefff1e4)
    at /build/buildd/blender-2.69/source/blender/python/intern/bpy_interface.c:274
#6  0x00414c8a in WM_init (C=C@entry=0x1984930, argc=argc@entry=1, argv=argv@entry=0xbefff1e4)
    at /build/buildd/blender-2.69/source/blender/windowmanager/intern/wm_init_exit.c:176
#7  0x003fbfc0 in main (argc=1, argv=0xbefff1e4) at /build/buildd/blender-2.69/source/creator/creator.c:1586
(gdb) l
1447    /build/buildd/blender-2.69/source/creator/creator.c: No such file or directory.
(gdb)

Looks like the debug package provides some symbols but not source (and I’m running out of space :P). So the error occurs on line 1447 of creator.c. I don’t know which package to install for blender source on Ubuntu (on Fedora I’d expect symbols to include more from the debug package…Ubuntu seems to do this differently).