Jetson TK1 Boot Issue

I have a Jetson TK1 Development Kit.

The Jetson TK1 Support site had a Readme that installed the Linux NVIDIA driver. I followed the Readme up to the end where it said to Reboot the system to have the graphical desktop UI come up. The problem is the board reboot with a blank screen after I ran the script in step 2.

The next thing I tried is installing the newest Linux Kernel available (Linux For Tegra R19, Kernel version 3.10.24) from the Jetson TK1 support site. I followed the Quick Start Guide located at the bottom of the Jetson TK1 support site. Step 4 of the Quick Start Guide says: “The target will automatically reboot upon completion of the flash. The command prompt will show up over the display that you have attached to the target.”

I did see the target reboot but it just reboot to a blank screen. I also read in the Release Notes that it’s a known issue that after flashing the device a hard reboot is required. I tried a hard reboot and now I see the bios boot up and it hangs at: “[7.554294] EXT4-fs (mmcblk0p1): mounting ext3 file system using the ext4 sybsystem”.

Has anyone come across the same issues?

I don’t have that issue, but I typically have to attempt a boot up 2-3 times before I get something other than ‘No Signal’ out of my hdtv. Boot, no signal for a couple minutes, hold down power button until board is kill, repeat until successful. Once I see the terminal stuff scrolling, I’m good. I have seen one of the loading indicators say fail, but it scrolled by too fast for me to read which one. It still booted into Ubuntu anyway.

Edit: I’ve discovered if I leave my TV off when I power up the jetson for about a minute, then ubuntu loads properly and is waiting for me when I power on the TV.

I also haven’t seen this issue, but I did notice that the first boot after installing the drivers had a blank screen for 20 seconds before the Ubuntu desktop was displayed.

Maybe you can connect a PC to the serial port and use a terminal program to see if there are console messages. You can also use the serial port connection to view log files for any clues as well.

I see the exact same behavior as @Ramsey describes.

I think the failure is “bluetooth”.

It’s recommended to check the kernel logs over the UART if there are problems that prevent using the display normally. And when asking help in that kind of situations, it’s a good practice to attach the log as asking for that is probably the first response anyway.

I did see the same behavior, but only when using a very old Sony Bravia as the HDMI monitor. Substituting a Bravia made in 2010 gives me a working display, though it has some issues. Something to do with EDID detection not being useful or erroneous.

Even when the first display was not working, I was able to log on to the machine using SSH. Give that a try, and if you get in, take a look at the /var/log/Xorg logfile. Between that and dmesg the problem may perhaps be revealed.

Note: This only covers HDMI displays. I haven’t yet tried any CRTs on the VGA port.

Cheers,

I have the same issue. I did notice when I ran the Nvidia installer script it procuded the following lines towards the end:

"

Installing the board *.dtb files into //boot
Success!
/home/ubuntu/NVIDIA-INSTALLER
Removing installation files…
Configuring the desktop, please reboot to take effect
mv: cannot stat ‘/etc/init/lightdm.override’: No such file or directory
ERROR: desktop UI may not display!

"

Looks like this is causing the problem? Is there any way I can work around it without having to recover the Linux installation on the board?

Thanks

I just ran the installer script the second time, even though the Nvidia README file states that it should be run only once. But that apparently fixed the problem I had and now I am getting Ubuntu desktop on my HDTV. Not sure if it will work for others having the same issue though…

Edited my comment above, but it doesn’t seem to have bumped the thread. :)

How do you run the installer the 2nd time, please advise…

I just “successfully” flashed a Jetson Tk1 from 19.2 to 19.3 using steps 1-3 here:

https://developer.nvidia.com/sites/default/files/akamai/mobile/docs/l4t_quick_start_guide.txt

Now when I power it on, it boots to a blank screen. Because it’s known to be flaky from the discussion above, I’ve tried the reset button about 10 times, power off button about 10 times, and remove power supply about 10 times. I checked the HDMI cable and display work with another Jetson TK1 that I haven’t yet flashed.

  • "It's recommended to check the kernel logs over the UART if there are problems that prevent using the display normally. And when asking help in that kind of situations, it's a good practice to attach the log as asking for that is probably the first response anyway."
  • This is a great suggestion! I’d love to see the logs, but don’t know how to see them with my host via the serial port. Any pointers there? Which logs? What’s a simple command to set up the serial connection from the host?

    I use gtkterm on linux, or PuTTY on windows…lots of serial console apps available free. Linux version is better behaved IMHO. Settings are for the serial port, and because I use a serial-to-USB adapter, my host sees it as /dev/ttyS0 or S1 (I have 2). You can use a 9 pin cable directly, port name would change.

    Settings are speed 115200 (115.2k), 8 bits, no parity, 1 stop bit, and XON/XOFF flow control (8N1). Turn that on before starting Jetson, and it will simply be a terminal that works even as early as boot loader stage. Logs are in /usr/var/ for X11, although dmesg might show something.

    FYI, it seems a lot of mystery problems can exist if you unpacked the L4T without root permissions, and without preserving permissions. Consider carefully unpacking again the first thing to verify (for example, non-root can’t create some device special files).

    Hello,
    I have the same boot issue.
    After flashing the 19.3, the boot is ok.
    Troubles are coming after upgrading packages.
    After restart, i have the blank screen.

    dmesg : http://pastebin.com/bEE2CZsS
    xorg : http://pastebin.com/8dgJtu44

    Ctrl+Alt+F1 is working. System is running.

    From the xorg:

    [    16.779] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
    [    16.779] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
    [    16.779] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
    [    16.779] (EE) NVIDIA(0):     you continue to encounter problems, Please try
    [    16.779] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
    

    The NVIDIA-provided X11 files like libglx.so may have been overwritten when you updated.

    Go back to the Tegra124_Linux_R19.3.0_armhf.tbz2 package you used to initially flash R19.3. Contained in it will be another archive located Linux_for_Tegra/nv_tegra/nvidia_drivers.tbz2. Extract nvidia_drivers.tbz2 and look in usr/lib/xorg/modules/extensions folder where the NVIDIA version of libglx will be located. Copy this libglx to the same location on your Jetson.

    Thanks,
    It worked !

    I still have these errors on the xorg log :

    [ 15.972] (EE) NVIDIA(0): Failed to allocate NVIDIA Error Handler
    [ 16.273] (EE) NVIDIA(0): Failed to allocate NVIDIA Damage Manager

    Don’t know if they were already before package update.

    What kind of blank screen do you get. I got just ubuntu background and mouse cursor. Installing lxde and replacing libglx.so with l4t libglx.so solved my problem

    Wow, Thanks!

    Work for me too :D

    Hello. I am having the same problem.

    I have already re-flashed the board once. On running the updates the system is once again unable to boot to X.
    I am getting the same error as mentioned above. I have tried overwriting the libglx.so as suggested but this has not worked.
    Any further help on this will be appreciated.

    Does the “sha1sum -c /etc/nv_tegra_release” show all files are now ok? If not, what are the last 10 lines or so of /var/log/Xorg.0.log?

    Thanks this worked for me too! Was having the same problem after flashing.