jetson TK1 CUDA driver not fond

On my jetson TK1 board , i run simple martixMul sample , but i can’t
what should i do?

dpkg --list|grep ‘cuda’ :
ii cuda-driver-dev-6-5 6.5-14
armhf CUDA Driver native dev stub library

… etc…

nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2014 NVIDIA Corporation
Built on Thu_Jul_17_18:43:29_CDT_2014
Cuda compilation tools, release 6.5, V6.5.12

problem:
root@tegra-ubuntu:~/NVIDIA_CUDA-6.5_Samples/0_Simple/matrixMul# ./matrixMul
[Matrix Multiply Using CUDA] - Starting…
cudaGetDevice returned error code 35, line(396)
cudaGetDeviceProperties returned error code 35, line(409)
MatrixA(160,160), MatrixB(320,160)
cudaMalloc d_A returned error code 35, line(164)

I can’t run the deviceQuery same reson.

Which L4T version is used? I see CUDA is 6.5, which only works on R21.1. If you are using R19.x the mix with CUDA 6.0 is required.

Distributor ID: Ubuntu
Description: Ubuntu 14.04 LTS
Release: 14.04
Codename: trusty

& used R21 , ty

R21.1 is correct for use with CUDA 6.5. I don’t have this installed yet, so I don’t have the example under 6.5. I guess the first question is if anyone else has had this matrix example work?

If you used remote display on another machine this may be an issue. Was this displayed on the Jetson monitor or was it remotely displayed? If this is entirely text/command line on the example remote display is irrelevant.

EDIT: I find my version 6.0 works on R19.3. It might be a few days before I run R21.1 (I need networking on R19.3 for now), but it may come down to just how the example was built.

@linuxdev,
I ran it this morning, here’s the output:

[Matrix Multiply Using CUDA] - Starting...
GPU Device 0: "GK20A" with compute capability 3.2

MatrixA(320,320), MatrixB(640,320)
Computing result using CUDA Kernel...
done
Performance= 19.30 GFlop/s, Time= 6.791 msec, Size= 131072000 Ops, WorkgroupSize= 1024 threads/block
Checking computed result for correctness: Result = PASS

Note: For peak performance, please refer to the matrixMulCUBLAS example.

I compiled all the examples at once using the provided makefile in the samples folder.

@golend:
What are your $PATH and $LD_LIBRARY_PATH environment variables?