Jetson TK1 Jetpack Instal Packages Install Failure


For a assignment a group and I are working on a using a Jetson TK1 for image analysis. We are trying to get to the point of using Open CV and right now are having issues installing Jetpack. Does this issue below seem familiar and does anyone have ideas for how to solve it?

Following the quick start guide, we are getting package install failures far into the Jetpack Jetson TK1 host setup wizard process. After downloading and installation stages by the install wizard, we get the following error message:

Failed to install one or more of the following packages: g++arm-linux-gnueabihf gcc-arm-linux-gnu cuda-toolkit-6-5 cuda-cross-armhf-6-5 libgomp1-armhf-cross. Please make sure they are correctly installed with apt-get command before continuing.

This has happened for two separate new Ubuntu 14.05 insulations and attempts to install these packages as instructed has resulted in no packages found. Some have been found on Ubuntu’s packages pages but with instructions to not download them there directly but back with aptitude.

What are we missing to install these packages or are we going about this the wrong way?

Heres the guide we are using, with the latest files available from its instructions:
We are failing after the section “Jetpack” step #7

Thanks a lot.

Several people have reported some form of issue when installing via JetPack. FYI, JetPack simply bundles all of the individual packages and steps which you could do individually. I do not personally have an Ubuntu workstation, I use Fedora…so I’m relegated to using only the individual packages, and cannot test or reproduce what your particular issue is. However…

There have been several people with occasional issues, such as you describe, typically related SSH keys or certificates, or a package which the installer can’t find. I think in many cases people have an ability in the installer to find out the exact failure issue, and manually fix that one issue and have things continue (figuring that out may require poking around, it won’t be obvious).

Someone else may be able to give more information, but if you run from a command line via sudo, are there any command line information messages, or do any of the installer’s messages give more specific information?

Individual package install without JetPack is very reliable, it just takes a lot more research to figure out where everything is to get and install it. Once apt has the CUDA repository added, things tend to be easier.

Are you using VM or a machine without Cuda supported GPU or no gpu as Host, i think that might cause some issue, but im not sure either…

Hi, Inferno505,

JetPack is supported on Ubuntu 12.04 or Ubuntu 14.04.

If you met the above error, one of the reasons is sometimes the source repository might be temporarily unavailible. You may install the above packages manually in a terminal window:

sudo apt-get install g++arm-linux-gnueabihf gcc-arm-linux-gnu cuda-toolkit-6-5 cuda-cross-armhf-6-5 libgomp1-armhf-cross

Once the above packages are installed, you can continue with JetPack installation.

Hello again thanks for the help,
we seem to have had some form of success. The Jetpack install has been run, however it seems that we don’t have OpenCV like we expected (python scripts using cv2 libraries can’t be run).

In trying to manually get the remaining packages, we tried following the Ubuntu packages site instructions to use aptitude and synaptic, we used aptitude to get the packages in a certain order.

We ran:

sudo aptitude install cuda-toolkit-6-5
sudo aptitude install cuda-cross-armhf-6-5
sudo aptitude install libgomp1-armhf-cross

All of which went through an installation process successfully. At this point trying the same with g++arm-linux-gnueabihf and gcc-arm-linux-gnu now reported the packages were already had instead of not able to be found.

Then, after a failed run of the installer, closing it and trying it again went through the whole process correctly. This worked for both our 14.04 installations, a Virtual Box VM and dual boot with iOS on a 2012 MacBook Pro.

So besides the seemingly nondeterministic nature of it all, we think we got past this issue and hopefully it helps others if they have this problem. However does anyone have an idea of what we are missing for OpenCV? The instructions seemed to indicate we would have it now and yet all we have is an OpenCV4Tegra file with a single deb package and a shell script.

Thanks again for the help!

There have been several threads related to how OpenCV4Tegra is packaged causing conflict. When OpenCV4Tegra is present, it should satisfy the OpenCV package requirements. However, the default packaging seems to lose this information, while keeping the concept that you can have only the one or the other, but not both…so it becomes a bit like a dog chasing his own tail. Here’s a thread which might help: