Jetson TK1 L4T GUI crashes

Hello,
I have a problem with GUI. sometimes when I just click GUI elements - windows, buttons, etc. screen goes black, appears image " Nvidia beta driver" and goes to login screen.
I tried to reflash the board, but the problem persists.
I have this problem in Gnome and KDE too, it seems to be X server problem or something else.

They may be the same problems of https://devtalk.nvidia.com/default/topic/750844/frequent-x-server-crashing

Did the problems on that linked thread ever get resolved? This problem happens for me too and it’s very annoying when I’m in the middle of an install or something.

In my case, the problem has never appeared since I flashed L4T 19.3 into my Jetson.

I had that issue alot with 19.2 and just had it for the first time in 19.3 as well.
Out of nowhere, black screen for a fraction of a second, nvidia splash, login…
That is indeed super-annoying and I had hoped it would be gone by 19.3 but it wasnt.
Except for setting up LXDE I hardly did anything after the flash process so the root-FS and all was quite in its original state…
Anything I should check (logs?) next time it happens?

Is there any way to install L4T 19.3 without overwriting the eMMC?

I haven’t tried yet, but you could throw an SD card on it or SATA hard drive and tell it to install to that. Not sure if it would change the boot loader on Jetson itself, but in theory it wouldn’t need to. As is I believe Jetson checks for SD and SATA bootable devices prior to using the internal eMMC.

The internal eMMC target is mmcblk0p1. For an SD card it becomes mmcblk1p1. Not sure about SATA, I think it was just something simple like sda. I will probably try soon, depending on when my more invasive work starts.

Perhaps other people who have installed to SD card or SATA could mention if it altered their Jetson when the SD or SATA is unplugged?

The X display crashed a lot on me while I was utilizing a cheap USB 3 hub, when I swapped it out for another it seems to have stopped.

Just throwing that info out…

Hi, i too flashed L4T 19.3 and the problem persisted so i reinstalled unity, and ubuntu-desktop with the terminal and the problem seamed to disapear. I did it with the comand

sudo apt-get install --reinstall unity
sudo apt-get install --reinstall ubuntu-desktop

I hope this helps

I did follow both reinstall hints (though Im running LXDE) and I have been working a lot ever since without any crashes or sudden log-outs.

sudo apt-get install --reinstall unity
sudo apt-get install --reinstall ubuntu-desktop

Whoever tries this, should maybe check which files are actually touched by this procedure which takes only a fraction of a second.
Thanks Maxmolonky!