jetson-tk1 L4T R21.1 Logitech c920 webcam can't use

Hi all

I got a problem when I install L4T_R21 on jetson-tk1, the webcam can’t use.

I can use c920 webcam on L4T_R19 and use cheese to capture video form webcam.

but when I update to L4T_R21 than tk1 can’t capture video.

after that I reinstall L4T_R19 on jetson-tk1, it’s can capture video form webcam.

Does anyone have the same problem with this.

Use lsmod under 19 and see which modules are loaded. Also make a copy of /proc/config.gz. Between the two of those you will have information on all drivers present. Then under R21 do the same thing (sorry, you may have to reinstall unless someone else has that info). Post the lsmod while the camera is running on R19.

Hi chung646551,

This is a known issue in R21.1 and a fix is expected in coming release.

Hi Madhava,

Thanks your rpely, could you tell me? where have the Known issue in R21.1 about the webcam can’t use,

because I see the “TEGRA LINUX DRIVER PACKAGE R21.1” of KNOWN ISSUES section,

but I don’t see the know issue about this problem, so could you tell me? where have the known issue.

Hi chung646551,

This issue was missed in KNOWN ISSUES section.

However if you want to fix it locally , you have to compile the kernel image with below change:

go to kernel source code and look for “kernel/arch/arm/mach-tegra/board-ardbeg.c”

Inside the file change all the instances of “.unaligned_dma_buf_supported = true,” to “.unaligned_dma_buf_supported = false,” .

This change should bring back the C920 support.

or as said before , you can just wait for coming release where fix is applied.

Hi all,

I am try R21.2 with Logitech 920C and have some to chung646551 issues. It’s looks as UVC halted on capturing (cheese, luvcview, guvcview, nvgstcapture 0.10/1.0 has freezing).

Also, into R21.2 kernel sources all of “.unaligned_dma_buf_supported” is “= false”. And R21.2 release notes has like issue (Release notes, 2.10) but “The issue does not occur after rebooting” don’t work for me =(

P.S. Unfotunatly, I can’t try R19.3 as well as R19.3 simple filesystem is not accessed on https://developer.nvidia.com/linux-tegra-rel-19 (see https://devtalk.nvidia.com/default/topic/793782/embedded-systems/sample-filesystem-link-for-tegra-jetson-19-3-release-/post/4383869/ about it)

In continue to previous message. I am try R19.3 with R21.2 simple root filesystem - and camera works correctly.

Since last night I have tried to get my Logitech C615 to work with guvcview as well with no luck :(

The default version, 1.7.1 if I recall correctly, does a hard freeze, and the process is virtually impossible to kill (kill -9 often doesn’t work).

So I compiled 2.0.1 from source. This took some work: First get the source http://sourceforge.net/projects/guvcview/files/source/, and then install all the prerequisites:

$ sudo apt-get install luvcview libv4l-dev libudev-dev libusb-1.0-0-dev \
    libavcodec-dev libpng12-dev libgsl0-dev libportaudio-dev portaudio19-dev \
    libgtk-3-dev

And it still doesn’t work. There appears to be a kernel bug, noted on the Wiki at
http://elinux.org/Jetson/Cameras#USB_2.0_webcams_known_to_be_working but it seems rather odd - apparently reporting bogomips is causing guvcview to fail?

So there’s my 2-hour contribution to fixing this problem. Can someone bring this over the goal line? If there’s an NV engineer out with a spare few hours, help would be appreciated. Obviously, cameras are very important for users of the Jetson TK1 board, and it is frustrating that this useful tool - which used to work in L4T 19.x - no longer does.

Hi deppman. Please have a look at this link. https://devtalk.nvidia.com/default/topic/796989/

It appears to be an issue with portaudio. Portaudio is one of the dependencies for guvcview. I have also tested that guvcview works in l4t_r19.3 but not in l4t_r21.1 or 21.2

A fix for this is planned in an upcoming release.

Thanks,

-Chris