Jetson TK1 OS installation ERROR. "Mount failed for selinuxfs on /sys/fs/selinux: No such file directory"

I have tried to install of Jetpack 3.0 on Jetson TK1. But after installation completed the booting window shows this error message “Mount failed for selinuxfs on /sys/fs/selinux: No such file directory” and Jetson TK1 shut down showing this error.

Also tried Jetpack 2.0 , 1.1 all shows the same problem.

Error message picture: https://ibb.co/VVvWPm9

Normally SElinux is disabled, especially after a fresh flash. FYI, even if the kernel supports SElinux the status would in part depend on the file system itself having SElinux labels. During a flash the sample rootfs is first unpacked on the host’s “rootfs/” directory, and some operations edit this content; then a file the size of the partition is created, and under loopback, is formatted on the host as if it were a real partition. The file system type and options would be an exact match to the host’s ext4 default creation flags. If this includes SElinux, then the file system on the Jetson will also have those flags. However, unless something tells the kernel to enforce flags nothing will happen.

  • Does this change any actual operation?
  • On the host used for flash, what do you see from:
    gawk '/ext4 =/,/[}]/' /etc/mke2fs.conf
    
  • Is the host Ubuntu, and if so, which version of Ubuntu (e..g, 14.04 or 16.04)?
  • What do you get on the Jetson from:
    cat /proc/cmdline
    
  • What do you see from this command:
    getenforce
    

    Word of caution: You probably don’t have this command on your Jetson. If you do, then it was installed via:

    sudo apt-get install selinux
    

    …I don’t think that installing selinux actually activates anything, but it might. If you don’t have getenforce you should be “normal” in terms of what flash normally does. You could add that package and specifically test the output of “getenforce” after install and reboot.

One possibility is that this is just a note that SElinux isn’t being used (and it is not by default), but I don’t have that in my boot logs, so it is out of place and not normal.