Jetson Tk1 - run x86 code in a VM

http://linuxgizmos.com/emulator-brings-x86-linux-apps-to-arm-devices/

This VM from “Eltechs” called “ExaGear Desktop” should work on the Jetson Tk1 with much better performance than qemu. I already pre-ordered a copy and will write a review once it works on my Jetson Tk1.

It might be needed to re-compile the current L4T kernel with slightly different
configuration options to get the VM running.

Best Regards,
Peter Bauer
http://bitkistl.blogspot.com

First time in VM space:
ubuntu@tegra-ubuntu:~$ cat /proc/cpuinfo
processor : 0
vendor_id : Elbrus Technologies
cpu family : 0
model : 0
model name : Exagear Virtual i686-compatible CPU @ 1.00GHz
stepping : 2094
cpu MHz : 1000.00
cache size : 1024 KB
physical id : 0
siblings : 0
core id : 0
cpu cores : 1
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu pse tsc cx8 apic pge cmov clflush mmx pxsr sse sse2 nx pni ssse3 sse4_1 lahf_lm
bogomips : 1000.00
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical,

Cool :D

Great! Keep us updated. :D

With grinch 19.3.6 it is possible to use Exagear x86 vm in the following way:
-start a shell in the guest image (currently Ubuntu 12.04 LTS x86-32)
-install required ubuntu 12.04LTS x86 packages via apt-get install

  • run command line or GUI based applications without additional configuration
    ( I tried firefox_x86 )
  • install wine
    • run Windows applications
      ( I tried Windows Word viewer)

Next time I will have a look on multimedia support and performance in the vm world.

wrrrrr :) i’m waiting to monday for free jetson :> still working here

I compared running glxgears in the

  • exagears x86 VM to running direct on armhf.
    The result looks good:

exagear VM: Ubuntu 12.04 x86_32: 2400 FPS
native: Ubuntu 14.04 armhf: 2700 FPS

CPU load compared with htop was not much different:
exagear VM: using about 1 and a half CPU core
native: using about 1 and a quarter CPU core

I installed glxgears with:
sudo apt-get install mesa-utils both on the host and guest(VM) rootfs

So exagear is already out? These results look promising. I wonder if Steam could work like that.

The x86 steam Client when run in the VM shows the following error message:
Video Driver Problem
Your system is running older proprietary nVidia video drivers. Steam requires driver version 304.22 or higher.

It also says:
OpenGlx is not using direct rendering

Hey Nvidia - can you fix this ?
Any known workaround ?

Too bad. Hopefully It’ll get fixed soon. Thanks for trying

I did a Skype (x86 linux) install and did a call with my
Logitech C310 Webcam.

in short: it just works

  • The sound system from the guest (x86-32) system integrates nicely into
    the host (armhf) via pulseaudio.
  • Sound adjustment (mic and speaker level) is done on the host system.
  • The video resource /dev/video0 (uvc webcam) is used by the guest system without any problem.

Best Regards,
Peter Bauer

Very nice :)