Jetson TK1 - Unable to SSH to board from Centos 6.5

The unit is freshly unboxed. I have not performed any mods, changed any configs or updated any software.

I have performed the following and am unable to SSH to the machine

sudo arp-scan --interface=wlan0 --localnet
Interface: wlan0, datalink type: EN10MB (Ethernet)
Starting arp-scan 1.9 with 256 hosts (http://www.nta-monitor.com/tools/arp-scan/)
192.168.11.50	00:04:4b:3a:d7:90	NVIDIA
PING tegra-ubuntu (192.168.11.50) 56(84) bytes of data.
64 bytes from tegra-ubuntu (192.168.11.50): icmp_seq=1 ttl=64 time=4.43 ms
64 bytes from tegra-ubuntu (192.168.11.50): icmp_seq=2 ttl=64 time=4.41 ms
➜  ~  ssh ubuntu@tegra-ubuntu
Read from socket failed: Connection reset by peer

Any thoughts? I don’t have an HDMI monitor to try any other method.

Edit:

➜  ~  
telnet 22 192.168.11.50
telnet: 192.168.11.50: bad port
➜  ~  telnet 192.168.11.50 22
Trying 192.168.11.50...
Connected to 192.168.11.50.
Escape character is '^]'.
SSH-2.0-OpenSSH_6.6p1 Ubuntu-2ubuntu1

The telnet arguments are out of order, should be IP then port, but I doubt Ubuntu default settings allow incoming telnet.

The Jetson should be ok out of the box for ssh. Ping says it’s working. Most likely the cause is either from your CentOS being configured to restrict ssh on that network, or else the router somehow not being configured for it (some configurations might require dedicating a port to the Jetson to allow incoming connections not originated from the Jetson).

You should be able to see logs on the Jetson as you attempt ssh if you have the serial port console connected. If you lack a DB9-connector/NULL-modem-cable on your CentOS close enough to the Jetson you can get a USB cable with a DB9 on the end, a “serial UART”, e.g.:
http://www.newegg.com/Product/Product.aspx?Item=N82E16812156039

Life is much easier with a serial port console.

Your router might also have logs you can view as you attempt ssh, e.g., a web interface. I figure you must have a router because the Jetson was assigned a working address on a non-routable address through DHCP.

I corrected my telnet usage if you look at the snippet and it is working.

It isn’t an network issue as I can connect to other machines on the 192.168.11.X

I doubt its a router issue as Read from socket failed: Connection reset by peer almost always indicates SSH issue.

I’m thinking my ssh is trying to force use of an identity file. I’ll report back when I get it sorted.

I don’t have an adapter though I just placed an order for one.

I see now. Initially I only saw the first attempt. The telnet even proves the sshd is found on the port.

Which shows CentOS firewalling of the interface is not the issue.

I believe this is correct, especially because of the telnet showing sshd answering.

Normally you would only worry about the identity check from the ssh origination machine (CentOS). I don’t believe default L4T/Ubuntu would have any setup to deny incoming ssh connections prior to login attempts. If it had, then probably the telnet test would have been summarily dropped without offering any information (such as escape character).

This will be your best bet…it’ll allow you to run tail -f on logs or see dmesg output before and after the attempt. I have no doubt that the issue is not specific to Jetson hardware, but to find out exactly what is going on you’ll need to see logs on the Jetson/L4T/Ubuntu.

EDIT: Serial console setting 1152008N1.

So this was actually an issue with the install on the jetson board.

My issue is described in this blog post: http://ask.xmodulo.com/sshd-error-could-not-load-host-key.html

In case the blog disappears I will post the relevant steps here

#Let's check if SSH host keys are found where they should be.
$ ls -al /etc/ssh/ssh*key
#If they are missing or of zero size then do the following
sudo rm -r /etc/ssh/ssh*key
$ sudo dpkg-reconfigure openssh-server 
service ssh restart

Thank you!

I had exactly the same problem with my TX1 dev kit, fresh out of the box (May 2016). Your solution worked.