Jetson TK1 was working fine, but suddenly won't boot up and no power indicator lights

Been using the board for the past couple months with no issue, suddenly this morning it can’t turn on, and when the power is plugged on there’s no power indicator lights or anything of the sort.

Things I’ve tried:

  1. Measured voltage across battery terminals, reading around 12.2 Volts

  2. Connected to host Linux PC to see if anything came up for ‘lsusb’ when I hit the button combo for recovery mode, but it didn’t show

Need to use it in the next couple days and don’t have time to wait for the RMA replacement, any suggestions on how to fix this would be greatly appreciated

Hi Alhar7,

Did you measure the +5V_SYS and +3.3V_SYS? If no output you can try removing R6D2.
And what’s the voltage of VBAT_BKUP (C6D4)?

+5V_SYS and +3.3V_SYS to ground were both zero volts, same for C6D4.

When remeasuring the battery voltage across the terminals I accidentally shorted something with the probe and the board turned on with lights and fan spinning, removing the probe caused it to shut down and couldn’t replicate the spot I shorted it. This makes me think the whole board isn’t dead.

Would you recommend removing the R6D2 resistor as the next plan of action?

Removed R6D2 and C6D4 and still no luck with getting the Jetson to power on.

Any other suggestions would be greatly appreciated

What’s value of VDD_MUX and +2.5V_AON_RTC? These two rails should be normal otherwise the system can not power on.

If above two rails is normal, then check if the ONKEY_L signal can be driven low when press power button. And better to use multi-meter to check the current when press power button to see if any short happen.

Also there is a check list table in chapter 9.0 of OEM DG, you can do some checks based on power part.