[Jetson TX1] CUDA installation, OpenCV and YOLO

Hi, Thanks in advance:

Recently trying to run YOLO’s CUDA+OPENCV real time detection. Here are some issues I found during the process of setting up:

  1. At the first time, my Jetson TX1 freeze at the GUI due to my upgrade to ubuntu 16.04 (locally on the board). So I start to find way to flash the OS. I tried to install JetPack, but I always get the error ( You cannot install by the role of non-elevated users ). I solved that by creating a folder under the home instead of directly use from downloads.

  2. I also found the board’s main disc /dev/root only have 14G, so one time I download all those package, the computer crashed again. Any suggestions to avoid this? Should I add another Hard drive? How can I partition it well, and it won’t influence the performance?

  3. I previously mention I want to use webcam to run the YOLO. I have installed the CUDA, when I type
    nvcc -V, I got

nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2016 NVIDIA Corporation
Built on Mon_Mar_20_17:07:33_CDT_2017
Cuda compilation tools, release 8.0, V8.0.72

But when I try to run nvidia-smi, shows there is no command. And I can also run the ocean sample. I am wondering why. Did the CUDA install right or not?

  1. For the opencv part, does logitech HD920 webcam support the YOLO opencv configure? Also, would anyone give me any ideas about the very detailed plan of install the opencv on jetson? ( I tried the way on Opencv’s website, it still won’t work, seems it cannot detect my webcam but my webcam is on the lsusb) aka, opencv4tegra. I have failed this for a very long time, I need some helps. Because if I didn’t install the opencv at all, I will get same error, says cannot detect my webcam.

Best Regards,

You are more likely to receive useful answers if you post this to the sub-forum dedicated to the Jetson TX1: https://devtalk.nvidia.com/default/board/164/jetson-tx1/