Jetson TX1 Ethernet port (1000Base-T) loss packets @ 100 Meter using CAT6 cable

We are testing Jetson TX1 Ethernet port (using Iperf) to validate its ability to support 100 Meter cable length as defined by the IEEE standard
Cable type - CAT6 , Tester - Laptop (1G port) , Application - Iperf . The test runs for number of minutes @ room temperature
(We verified that this setting is working using 2 laptops @ 1G in advance)
For modes 10/100Base-TX there is no issue, [b]However at 1000Base-T Jetson TX1 reference design reaches ONLY 50 Meters !!!
We also checked Realtek RTL8153I-VC-CG (front line PHY for Jetson TX1 ) using same environment settings - succeeded to pass the 1G test

  1. Could you confirm that this module support 100 Meters @ 1G ?
  2. Have you encountered such issue?
  3. Any Errata relating to this item?
  4. Could you send module IEEE tests results , if any ?
  5. Other suggestions?

One thing I would test is to connect the Jetson (via short cable) to a switch (or bridge), and then test the results going through that switch and see if the switch reaches 100m. The idea being to see if perhaps degradation still exists at some length…if not, it tends to validate the degradation sensitivity is from the Jetson.

Also, running ifconfig before and after would allow you to see changes in errors/dropped/overruns/frame statistics. It might be useful to narrow down what part of networking is at issue.

Hi OA, regarding your words of “We also checked Realtek RTL8153I-VC-CG (front line PHY for Jetson TX1 )” , is it on a new device or a laptop with RTL8153I-VC-CG?

relating to the 1st feedback - I don’t understand your feedback , what should be the difference between LT and switch device for this specific issue ? do you mean that with switch device I can learn more on the status of a specific line ( counters … ) ?

relating to the 2nd feedback - it is a standalone device USB3 to 1000Base-T device see link attached ,
What do you mean by "new device " ? have you also tested RTL8153I-VC-CG device ?


Yes, a switch has a different PHY, and if 100m length issues persist under this alternate PHY it isn’t a Jetson issue; if 100m length issues go away, then it is related to the Jetson’s PHY. It’s narrowing down what the source of the issue might be.

Hi OA, as you know the Ethernet chip on Jetson TX1 is RTL8153AI-VB-CG, I am just curious about the ‘RTL8153I-VC-CG’ you mentioned, it means an other device not Jetson TX1?

Yes ,checked the RTL8153 functionality on another platform

The 100m 1000Base-T functional test passed during our internal qual, not sure why you failed on this. Did you try other cables/adapters? Do you have another TX1 board to check if still fail?

Thanks for the confirmation !
notes :

  1. using better qualified cable than required by the IEEE
  2. the cable has been checked with Ethernet tester

I wonder if this item hits some buffer management issue
sending UDP frames from each side succeed to pass ,
Any special Iperf configuration when using TCP ?


I am curious what is directly connected at the end of the 100m length? Is it a switch, or is it directly plugged in to another computer? If it is a switch, do you know if this switch aggregates packets (usually a feature which tries to increase performance…but it changes timing of packets and cause a flood of packets over a short burst of time even if the original packets are spread out evenly in time…this feature has been shown to cause issues on a Jetson and could be used only on TCP and leave UDP alone).

please refer to the test procedure described in previous notes
I understand your comments, however :

  1. System has been tested between 2 LT (NOT store and forward system)
  2. iperf set to transmit to constant Bit Per Second utilization
  3. UDP works fine

the only issue left - pass TCP using Iperf between 2 LT


Perhaps you could post the output of ifconfig at both ends? In part I’m curious if they both use the same txqueuelen, and if this shows errors/dropped/overruns. Additionally, I wonder if they use the same MTU.

Hi OA, we confirmed the test pass in our internal test. Did you try the default image and settings? If still fail, you might need to rule out the cable, connector and board issues.

What include this internal test ?
Could you elaborate the settings ? what application you have used ?


JetPack 2.3.1 (L4T 24.2.1) in download center, Iperf commands are as below:

Windows side

iperf -s -u -i 2

TX1 side
root@tegra-ubuntu:~# iperf -c -t 300 -u -b 1000m -i 2 -P4

Following above recommendation test results shows BW ~500K
tested on TX1 reference design and 100M cable (checked with SmartBit tester)

Please advise ,

Are there any network errors? Dropped packets? Collisions or overruns?

Our test is with Iper 2.0.5.

~500K is too low, seems like a hardware or connection issue. Do you have another TX1 board to compare?

No, I have only one TX1 board
relating to previous post - I don’t see any errors