Jetson tx1 not booting up

After following the quickstart guide I tried starting the tx1 board by pressing the power pushbutton. The power and soc leds lightup but there is no video output nor do any other peripherals seem to be alive (USB/ethernet).

The weird part is that the board did start twice out of the numerous times I have tried starting it. Is there any jumper that I am missing? Any ideas?

The JTX1 comes with Ubuntu Linux on it, and some of the nVidia-specific files are there but waiting for completion of install before full hardware-accelerated access is installed. Sometimes not having that completed may make it difficult to get video working, depending on monitor. Having video would of course make finishing the nVidia-specific file install easier…but if you need the files for video to work, it’s a problem.

You might try unplugging the video connector and plugging it back in. Double check with your router and see if an IP address was assigned, you could also log in via ssh (you said ethernet doesn’t work, but it might just be a router issue and not a Jetson issue). If you flash the Jetson, then there is a step in the process which is equivalent to the nVidia-specific file install completion. Also different monitors with different specs and different cables may also work (just don’t ever use the 15-pin D-sub connector, this is guaranteed to fail). Finally, a serial console is the most reliable access you can get. See:
http://elinux.org/Jetson/TX1_Serial_Console

I came to the conclusion that ethernet is not working because the leds on RJ45 port on the board don’t lightup. Apart from that none of the other peripherals (USB/HDMI) are working. I tried accessing JTX1 using UART but it doesn’t show up on the serial console.

It seems to me ubuntu itself does not boot up. I am starting to think there could be some issue with the power on the board. Maybe insufficient voltage? But the SOC and PWR leds do lightup and I am getting 3.3 volts between vcc and gnd pins of the GPIO header.

If serial console has no output, then there is a good chance of hardware failure. There is one last thing to perhaps test before going for RMA…see if the Jetson shows up when in recovery mode.

If you connect the supplied micro-B USB cable to the Jetson and your desktop host, and put the Jetson in recovery mode (hold down recovery button, either tap power on if system is down or reset if system is already up), your host should see the Jetson on USB. This command would have output, rather than being blank:

lsusb -d 0955:7721

If the Jetson fails to show up even then, go to near the top of this URL and look for “RMA” to see RMA procedure:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

If the recovery mode Jetson shows up on USB, then it might be worth further testing.

Thanks for the reply. Indeed there is some glitch with the board. To successfully start the board I now follow these steps:

  1. With the power cable disconnected, press the power button multiple times (probably has something to do with the capacitor?).

  2. Connect the power cable and press the power button to start TX1.

  3. After a couple of minutes connect the HDMI cable.

The board always starts this way. Weird, but works.

Sounds like you ran into this issue:
https://devtalk.nvidia.com/default/topic/946733/jetson-tx1/the-power-button-does-not-turn-on-the-carrier-board-why-/

Wrong Topic, sorry