Jetson TX1 -> Pip wheel Tensorflow 1.0.1 for python 3.5

Hey everyone,

Using this blog: [url][/url] we managed to build wheel file for latest tensorflow. Since I couldn’t find whl file online and we spent a lot of hours building/debugging I thought this file could be useful :)

Link: [url]tensorflow for Nvidia TX1 · Issue #851 · tensorflow/tensorflow · GitHub

Thanks dkop, I am also curious about how to install the latest Tensorflow on Jetson TX1, I am currently playing with r0.11.

Hey Ruih,

if you are using python 3.5 you can download provided whl file and then install it using pip (“pip install NameOfWhlfile”)

BTW, Has Nvidia solved the issue mentioned? According to this post, this may due to a bug of nvcc. An expert in NVIDIA says they solved it with their internal nvcc compiler, which is not yet available in JetPack. Maybe next release of JetPack (3.0 on March 14) will solve it. So I’ll update this post then. :)

Fix is only available for Jetson TX2 :'(

Hi guys any news? if it is possible to install tensorflow 1.0 in the jetson tx1 without problems, now that the jetpack 3 is available, or is there any problems yet?

Unfortunately, the wheel file fails with this message:

Command “/usr/bin/python3 -u -c “import setuptools, tokenize;file=‘/tmp/pip-build-xfb283r0/numpy/’;f=getattr(tokenize, ‘open’, open)(file);‘\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /tmp/pip-lf99jqr0-record/install-record.txt --single-version-externally-managed --compile” failed with error code 1 in /tmp/pip-build-xfb283r0/numpy/

Any idea how to proceed? This is a relatively fresh install/flash of the TX1 itself. The only other thing I’ve done since then is try (and fail) to get the step by step instructions from Yuthon’s blog working.

I would also like to know if JetPack 3 solves the problem.


You can find pre-built wheel files for Tensorflow 1.3.0 for TX1 and TX2 here GitHub - jetsonhacks/installTensorFlowJetsonTX: Install TensorFlow on the NVIDIA Jetson TX1 or TX2 from the provided wheel files

He did a youtube video with the whole process, check that out as well (username jetsonhacks)

I just want to install tensorflow 2 on jetson TX1 but there is no way I can do that…
there is no version of tensorflow compatible with python 3.6 that was installed on jetson by the SDK manager.
there is no wheel file of tensorflow compatible with Arm64
I have downloaded the Tensorflow .whl file from Nvidia repo and when I want to install it, it returns the error (h5py is not compatible with python3.6)
when I write pip install tensorflow it tells me there is no module!!!
Why is it so hard and painful to install a library for this board?!!!
is there any way for installing tensorflow without suffering on jetson TX1 ?