Jetson-TX1 QT5 and qt-gstreammer Installation

What is the proper method to install QT5 and qt-gstreammer on TX1.?
Do i need to compile Qt5 from source or any package available that i can install from apt-get install?
i think “apt-get install qt-sdk” will install qt4 on TX1 right??

I don’t know which repository Qt is from, and I have them all enabled, but I get a lot of qt5 packages available when I run:

apt search qt5

(If you add a repo don’t forget to run “apt update” before the search query.)

I had tried “apt-get install ubuntu-sdk”.
I think this has installed Qt 5.2.1 and also Qt creator.

I can see Qt version in “Tools->Options->Build & Run”
I am new to Qt. So is this means qt is installed?

I also tried to compile qt-gstreamer-1.2.0 using

cmake .. -DCMAKE_INSTALL_PREFIX=/usr/local/ -DQT_VERSION=5

but this gives warning as below.

-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
   * QtQuick1 (QtDeclarative) (5.0.0 or higher)  <>
     Required for building QtQuick1 support


-- Configuring done
-- Generating done
-- Build files have been written to: /home/ubuntu/qt-gstreamer-1.2.0/build

But i think that’s optional package. So i can able to make & make install.

I can run Qt sample project.
But i want to test qt-gstreamer. So i have found one example

When i try to build that project it gives me error “Qt5Gstreamer-1.0 development package not found”. Which is defined in project .pro file in

PKGCONFIG += Qt5GStreamer-1.0 gstreamer-1.0 gstreamer-video-1.0

so how can i add qt-gstreamer location in QT?

Also if i remove Qt5GStreamer-1.0 from PKGCONFIG. i got QGst include error.
so i added

INCLUDEPATH += /home/ubuntu/qt-gstreamer-1.2.0/src

But now i am getting undefined reference to all QGst functions (ex:‘QGst::init’).

So how to resolve this error?

I’m not much of an Ubuntu package manager guru, I tend to have to look up things in the man pages to get the right commands. However, here’s some commands you may find useful (you may need sudo for some of them):

# For installed packages:
apt list --installed
# For installed packages with lower case "qt5" in the name:
apt list --installed | grep -i qt5
# For information on package "somepackage":
apt show -a somepackage
# These files have listings of files of packages:
cd /var/lib/dpkg/info ; ls *.list
# Searching for packages with "qtquick1" in the name:
apt search qtquick1

Note that when listing qtquick1 packages that a “dbg” package is for debugger symbols…needed only if you are using gdb to trace through a problem going into that package’s files. The “-dev” version has headers and things needed to compile programs using that package…this is probably what you want (trying to install a “-dev” version would likely also install the base library as a dependency if it is not already installed…this is what you want). In the above qtquick1 search, I would estimate that this command would be useful for installing “QtQuick1 (QtDeclarative) (5.0.0 or higher)”:

sudo apt-get install qtquick1-5-dev

Hi linuxdev , do u have any ideas on how to install qt 5+ on the TX1 board?

Hi RiteshPanchal, do u sovled your problem then ? How do u install QT5+ on the TX1 ? did that work successfully?
If u made it , please let me kmow, thank you very much!

I’m not where I can really check right now, but I did see Qt5 already installed…just not the development package (in which case you could run precompiled Qt5 packages, but not compile or build them). The dev packages typically just supply headers, and perhaps system configuration information. It is possible a dev package can simply be a tarball source install of headers.


Use following command to install QT 5.2.1 on TX1.

sudo apt-get install ubuntu-sdk

And if you want to install latest QT like 5.7 or 5.8, you have to build source from github.

has any one used QT to view Nvidia UI Composer projects on TX1 ?

dose the installed qt5 support linuxfb ??