Jetson TX1 USB unresponsive after updating to ubuntu 16.04

I updated my Jetson TX1 to Ubuntu 16.04 and now the USB port seems to be dead. I have tried to remote desktop into the Jetson, but I get no response. I can see the Jetson (tegra-ubuntu) on the wireless network, but can’t ping it.

Did I just brick this thing? Is there anything I can do to roll back the update or does anyone have a suggestion on how to access it?

Hi, can you try to flash via Jetpack3.1? It is Ubuntu 16.04 by default.

FYI, regardless of what went wrong your Jetson hardware should be completely safe and not harmed. If the suggested JetPack3.1 flash does not succeed you should give details of your host and what does or does not work in a bit more detail (e.g., which USB connector, router logs).

I was running 14.04 up until this weekend and attempted an upgrade to 16.04. After the restart there was no response from the USB Type A port.

When I power up the TX1 I get the welcome screen on my monitor and a notification that it has connected to my home network.

Unfortunately the USB Type A does not respond. I have tried every keyboard and mouse I can find and there is no response to any of them. I attempted to remote desktop into the Jetson, but do not get a response. I can’t ping it from windows either.

I will try and go through the recovery process this evening. Is there any way to recover if the micro-USB is not working either?

Keep in mind what you are seeing is very very likely a software error and not a hardware error. Holding down the recovery button while power either starts up or cycles to on puts the Jetson in recovery mode and won’t care how badly failed any software is…it’ll still work. Very likely the flash actually succeeded, but some step in the process went bad.

Should the micro-USB hardware fail you’d need to RMA. I’ve never heard of a bad flash causing a hardware failure…this isn’t particularly sensitive to bricking the way a motherboard BIOS is during a BIOS flash (Jetsons don’t have a BIOS…the host PC plus driver package is essentially the BIOS during a flash).

Typical issues with a bad flash would be incorrect permissions on the host or incorrect use of sudo (depends on how you flash). VM hosts tend to fail due to having bad USB behavior.

Thanks for your response. I will try recovery mode.

The odds of this being a user error and a problem with the software update (libusb or something) are around 99.9%.

Note that recovery mode won’t actually change the Jetson in any way…it’s the driver package which makes the changes when is run (and JetPack is a front end to So you can check recovery mode and experiment with it and not be afraid of anything being changed or erased before running an actual flash.

I can’t access the Jetson even when I try to connect with ethernet. The Jetson shows up on the wi-fi as tegra-ubuntu, but I can’t ping it or ssh. I get “Ping request could not find host tegra-ubuntu” or that PuTTY could not resolve host.

Do you have any suggestions on how to get into it?

How did you upgrade to Ubuntu 16.04?

Additional question: Since you said “tegra-ubuntu shows up on wifi”, does this mean you do not have wired? How is your host set up…does it have both wired and wifi? I’m wondering if your host route is not set to use the same wifi.