Jetson tx2 audio gain output problem

I used rt5651 to output audio.
However, the audio gain is low, so it is hard to hear.
I tried the following as a way to increase the gain.

  1. rt5651 gain adjustment → max gain setting

    amixer cset -c tegrasndt186ref name=“x DAC1 Playback Volume” 175

    amixer cset -c tegrasndt186ref name=“x HP Playback Volume” 39

    amixer cset -c tegrasndt186ref name=“x OUT Playback Volume” 39

  2. Set master volume control

    amixer -c tegrasndt186ref cset name=“MVC1 Vol” 16000

I tried the above method, but the audio gain is not significantly improved.

Please review how we can improve.

Hi there,

I am afraid I am unable to help with this specific question, but if you don’t mind I will move your topic to the Jetson TX2 experts and I am sure you will receive great support.

Thanks!

Hi Sangjina,

I see that you have set peak gain on codec and MVC side. But confirm if MVC is included in the playback path through below settings

amixer -c tegrasndt186ref cset name="MVC1 Mux" ADMAIF1
amixer -c tegrasndt186ref cset name="I2S1 Mux" MVC1

If you have included MVC in the path, you could do I2S loopback once and check if data signal levels are fine uptil Jetson. Below additional controls/commands will be needed for loopback

amixer -c tegrasndt186ref  cset name="ADMAIF1 Mux" "I2S1"
amixer -c tegrasndt186ref cset name="I2S1 Loopback" "on"
arecord -D hw:tegrasndt186ref,0 -r <rate> -c <channels> -f <sample_format> <out.wav> 

If the data is getting de-amplified inside codec (i.e after getting transmitted from Jetson I2S to codec), you might need to check once with codec vendor as I see that you have set all possible volume related settings on codec side

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.