Jetson TX2 Developer Kit - error

We have a problem with Jetson TX2 Developer Kit.
The carrier fails to power up. On power supply connection no LEDs are lit, and if power button is pressed, the red LED will light up and fade down.
Installing the same TX2 module on another DevKit carrier and using the same power supply shows that the problem in carrier itself - LEDs light up correctly and OS boots successfully.
What can be the problem?

Hi tome60c2,

Have you tried to press and hold the power button for few seconds?.If you haven’t tried please try the suggested step to power up your carrier board.

Thank you, your suggestion worked for us, but this is not the regular expected behavior we are used to. As I mentioned before, in other DevKit carriers we have, a short press on the power button is enough to power up the carrier.
What can we do to fix it?

Is the version of issue board same as others? There is S/N label on board showing that.

Since long press can power on issue board, did you try set board aside without any power input attached for long enough time so as to let capacitors be discharged fully?

If same version, same test situation, the issue is till, you can run RMA for it.