Jetson TX2 does not have HDMI output

I have bought a Jetson TX2 and it is giving me some problems. I have connected all the peripherals as is said in the quick start guide and turn on the board. The problem comes when I can’t see nothing in my monitor. The monitor shows the message “No Signal”. I tried with a HDMI-HDMI cable, later with a HDMI-VGA cable, and also tried with two different monitors, always with the same result.
I have serached on Internet and I see that this problem is usual but I can’t find the solution for my case.

Can you give some advise or solution for this problem?

I have modified your topic to be more specific to your true issue.

Have you ever flashed your device with Jetpack?

Hello WayneWWW, no I dont’t. Due to I can’t see nothing on my monitor I didn’t do anything with my Jetson. Could yo explain with more details how to do that?

Thank you, I have no previous experience with this products.


Please flash your board with Jetpack first. It may have some problem if you just use fresh device without any BSP (or unknown BSP).

Note that anything VGA is guaranteed to fail auto configuration of video (it might work if you are lucky). VGA isn’t supported since it isn’t possible for VGA to auto configure. Make sure your test case is pure HDMI (or an adapter with a monitor type supporting auto configuration, e.g., Display Port and DVI-D can work with an HDMI adapter).

Hello again, thank you for your responses. I could flash my Jetson but I have a question, it is supossed that the JetPack has to be installed or have I to install it? Because I don’t have anything of the pack installed and it is giving me an error when I try to install JetPack.

Why are you able to flash the device while you cannot install jetpack???
Could you elaborate the detail?

I have followed the steps to flash the board using a host Ubuntu PC. I just got an error message but the OS was flashed and worked fine so I thought that it was correctly upload, but I realized that for example TensorRT, cudNN, etc. has been not installed. How can this be possible?


If hdmi is working now, please file another topic for the jetpack installation. Thanks.

Okey, thank you and sorry.