Jetson tx2 ethernet connection lag

Hi,
We are having problems with our jetson tx2 platform. For this test, we use the Jetpack 4.6 and the development kit and configure a static ip. When we ping the jetson tx2 from a computer on ubuntu 20.06, a lot of packets are lost. We are connected directly from the computer to the jetson tx2 with an ethernet cable.

ping 192.168.2.240
PING 192.168.2.240 (192.168.2.240) 56(84) bytes of data.
64 bytes from 192.168.2.240: icmp_seq=1 ttl=64 time=2053 ms
64 bytes from 192.168.2.240: icmp_seq=2 ttl=64 time=1029 ms
64 bytes from 192.168.2.240: icmp_seq=3 ttl=64 time=5.00 ms
64 bytes from 192.168.2.240: icmp_seq=4 ttl=64 time=2.08 ms
64 bytes from 192.168.2.240: icmp_seq=10 ttl=64 time=2.11 ms
64 bytes from 192.168.2.240: icmp_seq=11 ttl=64 time=1.95 ms
64 bytes from 192.168.2.240: icmp_seq=12 ttl=64 time=2.76 ms
64 bytes from 192.168.2.240: icmp_seq=14 ttl=64 time=2.06 ms
64 bytes from 192.168.2.240: icmp_seq=16 ttl=64 time=1.61 ms
64 bytes from 192.168.2.240: icmp_seq=17 ttl=64 time=1.97 ms
64 bytes from 192.168.2.240: icmp_seq=18 ttl=64 time=1.87 ms
64 bytes from 192.168.2.240: icmp_seq=19 ttl=64 time=1.92 ms
^C
— 192.168.2.240 ping statistics —
19 packets transmitted, 12 received, 36,8421% packet loss, time 18205ms
rtt min/avg/max/mdev = 1.611/258.746/2052.844/610.275 ms, pipe 3

When we use a switch between the jetson tx2 and the computer, the problem is not appearing. Can you help us find how to resolve this problem wehn directly connected from computer to jetson tx2 please ?
Thank you

Not sure I can help, but keep in mind that “technically” you would “normally” need a crossover cable to go directly from host to host. Many NICs do have detection mechanisms such that you can run a “normal” (non-crossover) cable directly between NICs. Perhaps the issue is related to such a detection scheme. When connecting host to Jetson directly, are you using a crossover cable, or just a regular cable? If not using a crossover cable, then can you try with a crossover cable and see if results change?

Thank you for your reply. We use a regular cat. 6 patch cable. I think we will try with a crossover cable but the strange thing is that we don’t have this problem when we connect direcly the jetson to a computer on Windows. Also the use of crossover cable is not common anymore so we need to find a way to make it work with a patch cable.

I just tried wih a crossover cable but it didn’t work better.

Ok I resolved the problem by enabling the kernel config CONFIG_EQOS_DISABLE_EEE.
This issue was detected in this post https://forums.developer.nvidia.com/t/networking-performance-issue/168196.
Can someone at nvidia disable this kernel config by default for future releases as it is causing ethernet issues from computer host to jetson tx2 please ?

This won’t get disabled because some users may need the EEE function.

If you have requirement to connect to host directly, please just rebuild the kernel.