Jetson TX2 Firmware Not Found

While trying to install ROS on our Jetson TX2, we kept getting an error message that said we couldn’t install ROS packages because they depended on other packages within the package we tried to install.
After trying various things, we ran a command called aptitude and it erased much of the OS, including some of the firmware apparently.
We’ve been trying to flash a clean version of Ubuntu 16.04 on the machine since, but we keep running into issues…


  • Factory Jetson TX2 board - No modifications
  • Ubuntu 16.04
  • Error Code:
    ~$ xhci-tegra 3530000.xhci: cannot find firmware…retry after 1 second
    a bunch of other code regarding peripherals

    I’m unsure how to copy/paste the error message to display here, so ask me if you need a specific line.

    Hi blake.espeland,

    Already many developers installed ROS melodic morenia using Jetpack 4.2, following the instructions on ROS website and it worked without any issues, not sure which version of JetPack you flashed with your Jetson TX2 device.

    Here are the topic and githup as our reference:

    If you hover your mouse over the quote icon in one of your existing posts, then other icons show up. The paper clip icon is for attaching files.

    You might want to run this to see if anything is not “ok”:

    sha1sum -c /etc/nv_tegra_release