Jetson TX2 flashing with Jetpack 4.4

I’m trying to download and install the latest version of Jetpack onto my Tx2 board but the SDKmanager always comes up till 99.5% of creating the OS image and then it does not give me any sign of connecting the TX2 board into the force recovery mode. It just stops at “installing 18.14%”
I’m using a Mac with a dual Boot Ubuntu 18.04. There wasn’t any internal space on the Ubuntu partition and hence I downloaded both the files from the SDKmanager on an external hard disk which is always connected. Someone please help me out, I’ve been trying to flash the Jetson for the past 3 days and have tried everything, VMware, another PC and now this.

Also it throws this message

So, I also tried to manually flash the Board without SDK manager and this was the flashing error.
.

So I’ve Managed to get the WiFi working on my Ubuntu host system, thinking maybe it was a problem with the the host being connected through Ethernet and the target through WiFi. But whatever I try and do. I cannot seen make the SDK manager pop up the “SDK manager is about to flash your Jetson TX2” window. It creates the OS image and just gets stuck there.

So I made a little headway. But I’m stuck again after trying the manual flashing. Fixing the Boot ROM communication error. The flashing was stuck at making boot image for almost half an hour before I decided to end the terminal and try it from the SDK Manager. But the same installation error occurred even there.

Hi,

“Making Boot Image” is a work that only happens on your host. Thus, I would like to know if your disk has enough space for it?

Also, sdkmanager is also using this script (flash.sh) to do the flash work, so you could always use it to save your time.

Fixing the Boot ROM communication error.

How did you do to get this fixed? Generally we don’t have any software method to fix such problem.

so the terminal has finished “making boot image”, But this time It threw a different error:

nvidia_sdk/JetPack_4.4_Linux_JETSON_TX2/Linux_for_Tegra/rootfs/boot/extlinux/extlinux.conf is not found, exiting…

And I used a different dongle to fix the Boot ROM communication error (hardware issue)

Hi,

nvidia_sdk/JetPack_4.4_Linux_JETSON_TX2/Linux_for_Tegra/rootfs/boot/extlinux/extlinux.conf is not found, exiting…

This file should be prepared by sdkmanager.

Could you directly go to JetPack_4.4_Linux_JETSON_TX2/Linux_for_Tegra/rootfs/ and see if the rootfs is empty?

You could compare to any of your old jetpack release. extlinux/extlinux.conf should be there too.

Since your progress bar seems stopped at “installing 18.14%”, maybe the sdkmanager didn’t download the full rootfs at all.

I did go and check the rootfs file. It wasn’t empty, the rootfs file had a bunch of folders inside of it, some of them were empty some were full. but the “boot” file did not have aything called “extlinux” inside of it.
Yeah so before it had stopped at 18%, but after that I ticked the button to download now and install later. so the only thing that shouldve been left out was the installation part, which I thought i could do manually.

If you don’t know what is going on, there are some alternatives

method 1. delete the old JetPack_4.4_Linux_JETSON_TX2 and let sdkmanager to do the full flash

method 2. Download the rootfs from our dlc directly. Search rel-324.3. “L4T Sample Root File System”, download it and untar it to JetPack_4.4_Linux_JETSON_TX2/Linux_for_Tegra/rootfs/

I prefer method 1 because we don’t know what are missing in your previous installation. If some components other than rootfs are corrupted, you will still hit problem during flash or after boot up.

I see, but the thing is. this is the 3rd time I’ve removed and installed ubuntu and SDK manager from my system and everytime I plug it in. the SDK manager never gives me the pop up window for flashing I don’t know what the reason behind that is. but I will and try do it again. if not I will resort to method -2

I tried doing both the methods, but in the method-1 installation never gets completed because it gets stuck at 99.5% of downloading the OS files. so I tried to download the L4T sample root files from the NVIDIA website. the link you left but for some reason that didn’t have the “boot” file the flash.sh program is looking for.

Don’t bother flashing 4.4. It’s buggy and kills 2 of your CPU cores.

Hi noblehusein6,

Please follow the quick start guide after you download the rootfs. You need to run some script before running flash.sh.

https://developer.nvidia.com/embedded/L4T/r32_Release_v4.3/t186ref_release_aarch64/l4t_quick_start_guide.txt

So I was able to flash the Jetson Board successfully after a lot of time of diagnosing what was going wrong. It turned out it had to do with the Hard disk. The hard disk was formatted inn NTFS type but Linux needs an ext4 type to read and create the OS image, which is needed to flash. after I changed that the flashing continued normally and was able to install Jetpack 4.4 onto the board with no issues. just leaving this here for anyone who is also using a dual booted system with a hard disk, make sure to use an ext4 type one with Linux

1 Like

Do you flash to an external drive?

No, I just used the external drive to store the files I was downloading since I didn’t have space on my host system(Mac). The host was unable to generate the OS image required to flash the TX2 since my hard disk was in NTFS format which had some error working with Ubuntu’s platform, which is why I converted it to a ext4 type first and then proceeded.