Jetson TX2 GST-OMX Build Errors

Re-flashed Jetson TX2 with JetPack 3.3, full installation. Created an uninstalled GStreamer build under ~/gst/ with the create-uninstalled-setup.sh script from https://github.com/GStreamer/gstreamer/tree/master/scripts. Downloaded and built sources from L4T Sources (https://developer.nvidia.com/embedded/dlc/l4t-sources-31-0-2). Built gst-egl and added paths to the build environment script to include:

#Gstreamer egl libraries
LD_LIBRARY_PATH=$GST/gst-egl/ext/eglgles/.libs:$LD_LIBRARY_PATH
DYLD_LIBRARY_PATH=$GST/gst-egl/ext/eglgles/.libs:$DYLD_LIBRARY_PATH
GI_TYPELIB_PATH=$GST/gst-egl/ext/eglgles/:$GI_TYPELIB_PATH

LD_LIBRARY_PATH=$GST/gst-egl/gst-libs/gst/egl/.libs:$LD_LIBRARY_PATH
DYLD_LIBRARY_PATH=$GST/gst-egl/gst-libs/gst/egl/.libs:$DYLD_LIBRARY_PATH
GI_TYPELIB_PATH=$GST/gst-egl/gst-libs/gst/egl/:$GI_TYPELIB_PATH

export PKG_CONFIG_PATH="
$GST_PREFIX/lib/pkgconfig
:$GST/gstreamer/pkgconfig\

COMMENTED MANY OF THESE LINES OUT FOR BREVITY

:GST/gst-egl/pkgconfig\ {PKG_CONFIG_PATH:+:$PKG_CONFIG_PATH}"

No problems so far, all modules build without error, until gst-omx. The above environment mimics another working environment of a previously flashed Jetson TX2. Not sure what is different here.

Follow readme.txt instructions. Step 5 and 6 seem to conflict.

  1. ./autogen.sh
  2. ./configure

So I’m just passing:
./autogen.sh --disable-gtk-doc --with-omx-target=tegra

and then (already ran make once at this point):

nvidia@tegra-ubuntu:~/gst/master/gst-omx1$ make
make all-recursive
make[1]: Entering directory ‘/home/nvidia/.local/share/Trash/files/gst-omx1’
Making all in common
make[2]: Entering directory ‘/home/nvidia/.local/share/Trash/files/gst-omx1/common’
Making all in m4
make[3]: Entering directory ‘/home/nvidia/.local/share/Trash/files/gst-omx1/common/m4’
make[3]: Nothing to be done for ‘all’.
make[3]: Leaving directory ‘/home/nvidia/.local/share/Trash/files/gst-omx1/common/m4’
make[3]: Entering directory ‘/home/nvidia/.local/share/Trash/files/gst-omx1/common’
make[3]: Nothing to be done for ‘all-am’.
make[3]: Leaving directory ‘/home/nvidia/.local/share/Trash/files/gst-omx1/common’
make[2]: Leaving directory ‘/home/nvidia/.local/share/Trash/files/gst-omx1/common’
Making all in omx
make[2]: Entering directory ‘/home/nvidia/.local/share/Trash/files/gst-omx1/omx’
CC libgstomx_la-gstomxvideodec.lo
gstomxvideodec.c: In function ‘gst_omx_video_dec_reconfigure_output_port’:
gstomxvideodec.c:2341:10: error: ‘OMX_COLOR_Format10bitYUV420SemiPlanar’ undeclared (first use in this function)
case OMX_COLOR_Format10bitYUV420SemiPlanar:
^
gstomxvideodec.c:2341:10: note: each undeclared identifier is reported only once for each function it appears in
gstomxvideodec.c:2346:10: error: ‘OMX_COLOR_Format12bitYUV420SemiPlanar’ undeclared (first use in this function)
case OMX_COLOR_Format12bitYUV420SemiPlanar:
^
Makefile:716: recipe for target ‘libgstomx_la-gstomxvideodec.lo’ failed
make[2]: *** [libgstomx_la-gstomxvideodec.lo] Error 1
make[2]: Leaving directory ‘/home/nvidia/.local/share/Trash/files/gst-omx1/omx’
Makefile:526: recipe for target ‘all-recursive’ failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory ‘/home/nvidia/.local/share/Trash/files/gst-omx1’
Makefile:458: recipe for target ‘all’ failed
make: *** [all] Error 2
nvidia@tegra-ubuntu:~/gst/master/gst-omx1$

Also tried:
https://devtalk.nvidia.com/default/topic/984772/jetson-tx1/how-is-opengl-es-3-1-retrieved-on-jtx1/

No luck. Thanks for your help in advance.

The following solved my issue:

./autogen.sh --disable-gtk-doc --with-omx-target=tegra --disable-fatal-warnings CFLAGS="-I/home/nvidia/gst/master/gst-omx1/omx/openmax/khronos"

My tx2 flashed by jetpack3.2.1.
How can I set --with-omx-target,it configure failed with tegra.
Thanks

configure: using GStreamer Base Plugins in /home/nvidia/gstin/build/lib/gstreamer-1.0
checking for GST_GL... yes
checking for GST_ALLOCATORS... yes
checking for EGL... yes
checking for GLES2... yes
checking for X11... yes
checking for -Bsymbolic-functions linker flag... yes
configure: Using tegra as OpenMAX IL target
configure: error: invalid OpenMAX IL target, you must specify one of --with-omx-target={generic,rpi,bellagio,tizonia,zynqultrascaleplus}
  configure failed