Jetson TX2 KVM on L4T 28.2?

Greetings,
Since the last few days I have been trying to enable KVM on the Jetson TX2 board (L4T 28.2).
First I have built the kernel, enabling the virtualization + kvm option.

For this, I used the following tutorial: http://www.jetsonhacks.com/2017/07/31/build-kernel-ttyacm-module-nvidia-jetson-tx2/

Edit: I’m building the kernel with the script provided in this tutorial, I also added the “make dbts” instruction.

I got a compilation error when building the module, so I had to apply this patch:
http://mc.pp.se/l4t-sources-28-1.patch
*note that the patch is for version 28.1 but should work for version 28.2

This patch should also fix the following bug, but It doesn’t:

Apr 18 11:20:02 tegra-ubuntu kernel: [    0.413555] kvm [1]: error getting vgic maintenance irq from DT
Apr 18 11:20:02 tegra-ubuntu kernel: [    0.413613] kvm [1]: error initializing Hyp mode: -6

I think the device tree is not being updated correctly or that the virtualization extensions are not enabled by the BIOS.

Am I missing something?
Thank you in advance.

There are changes in location of device tree related content between R28.1 and R28.2. I have no idea if your patch was valid or not (I don’t know if it would fix anything), but you might explore “/proc/device-tree/” and see if your patch actually made it in. If not, then you might look at changes in how to flash device tree on R28.2.