Jetson TX2 Modules do not boot after flash

I recently received the Jetson TX2 Modules I ordered at the beginning of
the month. Unfortunately they do not seem to boot after flash. I have
tried flashing them with Jetpack 3.3 and Jetpack 4.3 using the sdk-manager
and a development board. The flash seems to indicate success but on the
subsequent boot there is no HDMI output and the NIC does not start-up. Can
you advise me on the expected Jetpack version for these modules? Do they
only support 4.5 or are they defective?

hello 376358551,

are you having any purpose to use the specific release?
we had Jetson TX2 DevKit flashed with every JetPack release before to confirm it worked, now the latest JetPack-4.5.1 release also works normally.
could you please gather the failure in details for reference,

FYI, the TX2 is normally reliable with flashing, but if you do have an issue, then you might try gathering a log on command line flash, and also providing a serial console boot log. For serial console, see:

In terms of command line flash, on your host PC (make sure it isn’t a VM), you can find the directory with the driver package here:

Within this, if you have flashed once, you will find “Linux_for_Tegra/rootfs/” has been populated. From “Linux_for_Tegra/” you could run this command for command line flashing in combination with creating a flash log (command line is the most simplified flash, and if something goes wrong, it will be fairly obvious):
sudo ./ jetson-tx2 mmcblk0p1 2>&1 | tee log_flash.txt
(then you could post “log_flash.txt” to the thread)

Btw, it isn’t unusual for HDMI to have some issue, but it is probably more unusual that wired ethernet won’t work. The virtual USB wired ethernet over the micro-B USB cable has a few more requirements. Serial console won’t care about any of that failure, it is one of the best debug tools you can get.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.