Jetson TX2 not booting anymore

Hello,
I don’t know in which category tu put that but my jetson TX2 is not booting anymore. I had an issue with the cudnn version installed and tried to change it without flashing it (cause i don’t have an available computer for jetpack at the moment).
And now it does not boot, after powering it, the NVIDIA logo appears and then it writes:
cp: not writing through dangling symlink ‘etc/resolv.conf’
[3.68] cgroup: cgroup2: unknown option “nsdelegate”
[4.80] using random self ethernet address
[4.81] using random host ethernet address
[5.55]using random self ethernet address
[5.561] using random host ethernet address

and then it stops.

Did anyone ever have a similar issue?
is it still possible to flash it to recover (once i put my hands on a computer that can run jetpack) ?

Any help is most welcome.

Moving to Jetson TX2 forum for resolution.

The error log on screen does not represent any error. It was also there in your normal boot up process.

The real problem you have now is the gdm3 is not able to initiate. The reason is unknown. You have to tell us what you’ve installed.

I guess you can still access the board by using ssh or change it to console mode by press ctrl+alt+F1~F5

Hello,

Yes I can still access it through ssh (I hadn’t tried it before). But I can’t change it to console mode, keyboard is not powered.

I did several modifications: I recompiled OpenCV to use Cuda (that went OK) then I tried to downgrade cuDNN from 8 to 7.6.5, that’s what I couldn’t do:I removed 8, tried to download and install 7 but it didn’t work and then I reinstalled 8.

Ok.

There are several things to check now

  1. Why the usb keyboard is also dead? Is this happened along with your this error? Could you ssh to device, connect the usb keyboard and use command dmesg on ssh terminal to dump the kernel log for us?

  2. What command are you using to downgrade and remove cudnn?

And one more note for you. If you want to save your time, re-flash the board is also an option. We may need a while to locate the root cause.

Hello,
The keyboard actually is ok, the board was not the problem.

I used apt-get --purge remove libcudnn8 libcudnn8-dev libcudnn8-doc
to remove

since lib v7 is not available via apt, i downloaded 7.6 version from the website untar it and copy to folder as specified here: https://docs.nvidia.com/deeplearning/cudnn/archives/cudnn_765/cudnn-install/index.html

I plan on flashing it once i get a tool computer for that but in the meantime, understanding what caused that might help me in the future!

Are you able to check whether restart gdm3 service can get the desktop back?

If not, could you restart the gdm3 and then share me the syslog?

Restarting gdm3 does not change anything.
service is considered “running”
here is syslog:syslog TX2 gdm3 restart.txt (40.3 KB)

Honestly speaking, reflashing the board will restore it faster than trying to find the root cause of this issue.

And we cannot tell the exact command to trigger this issue yet. Under such case, I would suggest you to re-flash the board.