Jetson TX2 not booting with Freeing unused kernel memory log

Hi Everyone,
I had been working with our Jetson TX2 machine and suddenly the machine had become unresponsive when I attached a SD card and tried formatting the SD card.

Considering the Jetson tx2 board to be hanging at this stage, I went ahead and plugged out the power connector cable from the board.

After attaching the power connector cable back to the board and pressing the ‘Power Up’ button, I am seeing the board displaying the message “Freeing unused kernel memory” and getting stuck in the boot process.

Any suggestions what has been happening and how this could be rectified? Looks like something had got corrupted and not allowing the boot. Will flashing a new OS Image from the host resolve this issue? If ther is any other way to bring up the board, please advise.

Thanks
M

Do you have a serial console? If so, can you attach a log? What was the exact format command?

If this isn’t a hardware issue, then flashing should resolve the issue. If you have not yet upgraded from the default image you will want to do so anyway since the R27.1 version is much more reliable. There will be a new update to L4T soon, so if flashing, check here for latest version:
https://developer.nvidia.com/embedded/linux-tegra-archive

I do not have a serial console attached and trying to bring it up.

We had earlier tried flashing image to Jetson TX2 through JetPack 3.0 but there always would be errors in communicating with the board. After repeated tries, we at one point managed to have a 2 way communication with the bootrom but image flash didn’t happen in that case.

Is there a way the image downloaded from https://developer.nvidia.com/embedded/linux-tegra-archive could be directly copied or extracted to an SD Card and possible to boot the Jetson TX2 from the SD Card with the required changes done for boot from SD in the config files?

Please let know if this is possible.

Thanks
M

All flash operation goes through the micro-B USB port in USB2 mode. If you are using a VM then this is extremely likely to cause problems. Is your host a VM? If you are using Virtual Box see:
https://devtalk.nvidia.com/default/topic/1001082/jetson-tx2/jetpack-3-0-freezes-during-flash/post/5175498/#5175498

There is no binary image available for download. If there were, then transfer of the image through the flash in recovery mode would still require that same USB connection to succeed…the error would be agnostic of whether it is a pre-built image or a generated image (or a clone image).

In the case of SD card rescue it may be possible to boot this way and dd an image to the eMMC. This is not advisable though unless you have previously set things up correctly. There are many hidden partitions related to boot which go beyond just the root partition. One of the things the flash software does is to assemble a matching set of images for those hidden partitions matching the hardware and boot configuration…sometimes you can just update the root partition, but sometimes this is not enough (e.g., a clone or rootfs update spanning an L4T version change is at high risk of failing to boot correctly…and if a previous failed flash changed something, then there isn’t much hope unless you’ve also generated all of the hidden partitions for dd as well).

Hi Everyone,
I am trying to flash the image to Jetson TX2 eMMC using the command flash.sh script.(I am using the flash.sh script and not flashing using JetPack 3.0.

The image flash to the eMMC happens successfully but when restarted the system comes up but I see the “The system is running in low-graphics mode. Your screen, graphics card, and input device settings could not be detected correctly. You will need to configure these yourself.” comes up.

Any idea what I need to do from my host PC to get this up?

How do I configure the screen, graphics card and input device settings on my own?

Thanks
M

Automatic query is through a wire in the HDMI cable. Is everything purely HDMI, or is there any adapter? Also, what is the output of:

sudo -s
cat `find /sys -name 'edid'`
exit

Also, does this show correct drivers:

sha1sum -c /etc/nv_tegra_release