Jetson TX2 NX Module flash fails

nvidia_sdk/JetPack_4.6_Linux_JETSON_TX2_TARGETS/Linux_for_Tegra

I tried nvautoflash.sh and got the following.
I tried flash.sh jetson-xavier-nx-devkit-tx2-nx mmcblk0p1
I also tried every jetson TX2-NX and every jetson TX2 .conf.

L4T BSP Information:
R32 , REVISION: 6.1
Error: probing the target board failed.

What else can I try to flash the os on the jetson-tx2-nx module?

Thank you,
Scott

hello whitesscott,

please put your device to enter forced-recovery mode and sharing $ lsusb for reference,
may I also know what’s your environment setups, did you using a desktop or Laptop, is it a VM?

Yes the module was in recovery mode and lsusb showed the usb Nvidia module. I’m in another location but the desktop computer is ubuntu 18.04. Using same set up I was able to flash 2 Jetson Nano modules yesterday with your guidance in re flash.sh.

I forgot to mention that I don’t see a bootloader/.conf that is solely for jetson-tx2-nx emmc. The sdkmanager, I think used the bootloader/jetson-xavier-nx-devkit-tx2-nx.conf and it failed to identify the board.
Thank you for your help.

hello whitesscott,

please toggle the board selection as TX2-NX from the SDKManager menu to try again,
you should also attach the details failure by export the logs for reference,
thanks

Hello,
Here’s the logs. It fails immediately when sdkmanager can’t identify the board.

thank you,
Scott

SDKM_logs_JetPack_4.6_(rev.1)_Linux_for_Jetson_TX2_NX_2021-09-08_18-52-09.zip (26.8 KB)

Hello,

Please close this issue. I tried the following again right after I’d booted host machine and before I’d done anything else and this time it worked. Thank you for your help.

sudo ./flash.sh jetson-xavier-nx-devkit-tx2-nx mmcblk0p1

Scott

1 Like

hello whitesscott,

thanks for updating, we’ll close this topic.
please initial another new thread if you need further supports.