Jetson TX2 NX pinmux spreadsheet crashing

I downloaded the latest 1.05 version of the jetson tx2 nx spreadsheet to change the pinmux and generate the .dtb file.

I didn’t make any changes to the spreadsheet as of yet, I just wanted to make sure that it works first. I clicked on the generate dtb button, then enter the board name, and I get an error #52 “bad file name or number” from visual basics. If I click on debug it brings me to the line of code: “Open PinmuxFilePath For Output As #PinmuxFileNum”.

I’ve tried this on more than one windows 10 machines and they don’t work. One co-worker happens to have a macbook and it works fine on his for some reason. I need this to work on my machine though.

Anyone else encounter this issue?

Hi luc4,

I’ve just verified on my Win11 PC to generate DT File for TX2-NX w/o any changes.

Why your error is from Visual basics?
Could you help to provide any error from your screen and every steps you did?

Excel uses visual basics to run the code to generate the dtb file.

Screenshot 2023-04-20 110656

I tried it on another coworkers pc on windows 11 and it works fine.

I click on the generate dt file button, then click yes to generate the device tree file, i leave the board name as the default (which works on other ppls computers) then click ok, then I get the error in the screenshot.

If I click on debug I get the second screenshot below:

The yellow line is where the program crashes.

Hey, in case anyone else experiences this issue. The Excel file was stored on OneDrive and I guess it didn’t like that. I saved it into my local drive and ran it from there and had no issues.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.