Jetson TX2 Onboard Camera Not Available

I have a problem with the onboard camera. It can’t be found. Below is the list of some of the ideas I have tried and their results:

An external webcam is successfully detected, but the onboard camera is not available:
ls /dev/video*:
ls: cannot access ‘/dev/video*’: No such file or directory

The GStreamer pipeline gst-launch-1.0 nvarguscamerasrc ! nvvidconv ! xvimagesink returns the following error which can be linked to the previous point:
Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
Setting pipeline to PLAYING …
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:645 No cameras available

(gst-launch-1.0:12204): GStreamer-CRITICAL **: 11:48:49.526: gst_mini_object_set_qdata: assertion ‘object != NULL’ failed
Got EOS from element “pipeline0”.
Execution ended after 0:00:00.038680491
Setting pipeline to PAUSED …
Setting pipeline to READY …
Setting pipeline to NULL …
Freeing pipeline …

The system logs show the following issues:
dmesg | grep -i ov5693
[ 3.297801] ov5693 2-0036: probing v4l2 sensor.
[ 3.302953] ov5693 2-0036: tegracam sensor driver:ov5693_v2.0.6
[ 3.453436] ov5693 2-0036: could not read otp bank
[ 3.469732] ov5693 2-0036: Error -121 reading otp data
[ 3.491193] ov5693 2-0036: board setup failed
[ 3.501243] ov5693: probe of 2-0036 failed with error -121

Information about the board:
cat /etc/nv_tegra_release
R32 (release), REVISION: 5.1, GCID: 26202423, BOARD: t186ref, EABI: aarch64, DATE: Fri Feb 19 16:50:29 UTC 2021

sudo apt-cache show nvidia-jetpack
Package: nvidia-jetpack
Version: 4.5.1-b17
Architecture: arm64
Maintainer: NVIDIA Corporation
Installed-Size: 194
Depends: nvidia-cuda (= 4.5.1-b17), nvidia-opencv (= 4.5.1-b17), nvidia-cudnn8 (= 4.5.1-b17), nvidia-tensorrt (= 4.5.1-b17), nvidia-visionworks (= 4.5.1-b17), nvidia-container (= 4.5.1-b17), nvidia-vpi (= 4.5.1-b17), nvidia-l4t-jetson-multimedia-api (>> 32.5-0), nvidia-l4t-jetson-multimedia-api (<< 32.6-0)
Homepage: http://developer.nvidia.com/jetson
Priority: standard
Section: metapackages
Filename: pool/main/n/nvidia-jetpack/nvidia-jetpack_4.5.1-b17_arm64.deb
Size: 29362
SHA256: a00c37f38c0e21f1c59c7c1edc638b2ef0f963ffa6c77de7734da7b80da34e4e
SHA1: e25760701cd4a994004ea9cbfdb073afcbb2cc46
MD5sum: f629f4b27a76d0f58ad8da12986a2da4
Description: NVIDIA Jetpack Meta Package
Description-md5: ad1462289bdbc54909ae109d1d32c0a8

Could you please advise?

Thank you very much in advance!

Hi,
From the log it looks like the camera module cannot be detected. Probably the board is broken. Please try re-plug in the board and power up. See if it can be detected after re-plugin.

Unfortunately, the re-plug did not help. The board looks optically also undamaged. Do you have any other ideas what else I could try?

If no, could you please advise, whether (and where) can I order a substitution for the camera together with the carrier board?

Thanks in advance.

Hi all,

I experienced this issue too on Jetson AGX Xavier with that same camera model, but I think it happens only on JetPack >= 4.5 because I tried on Jetpack 4.4 and it worked well. @DaneLLL do you know if it could be something related to version changing?

FYI, we had r32.6.1 with TX2 and AGX Xavier, both of them able to enable ov5693 for its functionality.