Jetson tx2 power up button don't work

I changed the /etc/lightdm/lightdm.conf file to disable my user account from automatic login.

After that I restarted the computer. I got many errors showing that I have problem to load graphic driver.

I tick the option to resolve the problem but none of that was helpful. System screen appear and disappear without having the ability to start.

I was obliged to force sutdown the motherboard by hold pressing the power on button.

After that nothing is working.

When setting adapter only red led is working. I tried many time to start by pressing the start button but nothing start,

I tried to console by serial console but the usb link is not detected.

Is there any indication to resolve the problem

This shouldn’t cause hardware failure, but it does seem suspicious when only the red light is on (the red light is normal, having only the red light after pressing power is not normal).

What you are describing about the problem loading a driver seems more like something a bad update would have done when it replaces the NVIDIA video driver with the Nouveau instead (in which case you could just put the NVIDIA driver back in place with a file copy). Did you do any kind of apt-get command prior to this?

If you disconnect all USB and HDMI devices (they are hot plug, you can plug them in later on in boot) does this still occur? If you do get power on again you might consider an emergency shutdown like this with the “magic sysrq” keys:

# Calls sync:
ALT-SYSRQ-s
# Remounts file system read-only:
ALT-SYSRQ-u
# Either hold power down as before or reboot (brings the system back up):
ALT-SYSRQ-b

Do you have a serial console available? See:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

I want to know if the problem is from the jetson tx2 itself or from the carrier board.

The serial console don’t work.

The most important for me is the data that I have inside. i want to know how to extract the data.

The problem is very urgent. I have to troubleshoot to know the source of the problem. Is it from the module itself or form the carrier board.

I wonder if I extract the module and place it on top of another jetson tx2 carrier. Will it damage the new carrier board?

The module was designed to be able to mount to any carrier. If you move the module from one carrier to the exact same model of a different carrier, then this should be a good test and should be harmless to the module. I’m not sure, but some modules use a Torx type screw, so this might be an issue if you don’t have the right tool (if you don’t have the right tool be very very careful to guard against metal shavings…I don’t know which modules have Torx screws versus regular ones).

The serial console is working. Can I restore my system using the serial console?

Can you give us instruction to clone the content of the memory and flash the system to make the start button work.

Can you give us instruction to clone the content of the memory and flash the system to make the start button work using the serial console?

It isn’t possible to clone or restore via serial console…the micro-B USB connector is the method for doing any clone or restore. If you are interested in cloning the instructions will differ depending on release. All of the newer releases (R28.1+) will go something like this when the Jetson is on recovery mode with the micro-B USB connected to the x86_64 PC host (beware this takes a lot of disk space and time):

sudo ./flash.sh -r -k APP -G backup.img jetson-tx2 mmcblk0p1

There is a description in the official documentation, plus:
http://elinux.org/Jetson/TX2_Cloning

When you clone you will end up with both a “.img” file and a “.img.raw” file. The “.raw” is the uncompressed (non-sparse) version which can be loopback mounted, examined, edited, so on. The much smaller “.img” file is “sparse” and can be used for flash, but cannot be mounted or examined (the Jetson understands this during flash). Either of these work for restoring a Jetson so long as the file is in the “bootloader/” subdirectory and named “system.img” during a restore.

Note that you cannot attempt two clones in a row, nor two flashes in a row, unless you restart the recovery mode between tries.

EDIT: A normal flash involves unpacking the sample rootfs in the “rootfs/” subdirectory, putting hardware drivers in via the “sudo ./apply_binaries.sh” script, and then a nearly verbatim copy of this becomes system.img when the “-r” option is not used. I say “nearly” because some content is added or edited in the “/boot” directory. Your cloned rootfs will have a “/boot” reflecting the flash.sh parameters during the original flash (e.g., the extlinux.conf).

I connected a serial console to Jetson TX2 following the tutorial: http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/.

I pressed the power button but without any message received. Only the red led is working.

How can I use the serial console to debug this problem and access to the eMMC memory?

If even a slight bit of the system had powered up it would have likely put out at least some text to the console. I do find it odd that any change in lightdm would cause power up to fail…it would not be at all unusual for graphical mode to fail or have some crash during boot once the Linux kernel starts with an invalid set of software…but something should have showed up if the cable is known to be set up correctly and power went on.

I do not believe there is any way to access anything with power delivery failing. Perhaps someone knows of the correct test points to look to see if one of the regulators failed. If you were able to try the module on a different carrier board the results would add valuable information, but short of this, checking regulator output would be the next step before an RMA. Can anyone name test points for regulator rails?

If you do want to RMA the information is near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

I understand that the failure is from the carrier and not from the module itself.

Do you know how to find the regulator failure and how to test and fix it?

This is why I’m asking if anyone else here can offer test points for any relevant regulator…I don’t know where to test, but a simple voltage measurement should do the job if you know the test points.

Hi bilel_bj, did you measure the power up sequence as showing in figure 3 of OEM DG? That could tell which phase might have problem. Please check that and do the test first, you can find the corresponding points to measure the signal by checking the schematic and PCB files in download center. Basically if the signal CARRIER_PWR_ON is normal, then the power rails in module should be normal too.

http://developer.nvidia.com/embedded/dlc/jetson-tx1-tx2-developer-kit-carrier-board-design-files