Jetson TX2 red screen after flash attempt


I am very new to Jetson and have a TX2 development unit.

I downloaded the SDK Manager and tried to flash the TX2 via USB connection in the Manager, going for software version 4.2.
– the Automatic flash did not even start, I got a general error (saying if it is connected and if some setup procedure has been completed : yes, it is running, setup: no idea).
– so I tried the Manual method. Turned off jetson. Then turned on, pressing the REC buttn (hold down), press the RST button, wait 2 sec and release the REC button. The screen was empty (black). At this time, the Manager seems to have started flashing it, the progress bat went up. Then, after the OS flash, the jetson rebooted (and the Manager was asking me to install SDK components - which I cannot as - see below).

Now, the jetson restarts, I see “Nvidia” on the screen, this goes away and I get e red screen. After a few min. the Jetson auto-reboots and the same thing repeats in cycle.

I do not know how to continue from here and help would be much appreciated. Thank you in advance!