Jetson TX2 Red screen?!


recently received a jetson tx2 to do some academic collaboration with my sister.

Ive literally just opened the box and the device seems to keep booting into a solid red screen. I would add that nothing has been installed / really done on the device as of yet. I was in the process of sorting out getting the IP to ssh into from my local machine (mac). However i think the only command i gave it was sudo ifconfig and then sudo reboot as i was about to install the GUI that comes with the device. After using sudo reboot the red screen issue has started. If i hard reset it runs several command at command line and then hits the red screen again.

I’m pretty unhappy as the device is almost brand new and ive only just turned it on.

Hi yes_yes_yall,

Let’s clarify the situation here. Did you install the BSP with Jetpack and the red screen starts??

Red screen is likely the login screen or your default desktop background. If your display is underscanning, you may not be able to see the surrounding UI such as the activity bar on the left side of Ubuntu’s Unity desktop environment.

However, if you did a “sudo apt-get dist-upgrade” or a “sudo apt autoremove” prior to reboot, you may have put the system in a loop in which the desktop environment does not fully load. “sudo apt-get update” and “sudo apt install [Pkg_name]” should work just fine, though.

Please re-flash your device with JetPack to see if the issue resolves.


Hi Barrett,

I think this is what happened. I changed the aspect ratio on my display (using a HDMI TV due to lack of monitor!) as the edges of the command line had been chopped off. I re-flashed which was semi successful (CUDA etc did not load and it struggled to get a valid IP) however i subsequently dug around the forums and followed the instructions to only run the post flash installations and everything appears to be working now.

Thanks guys :)

I was also facing same problem of red screen almost every time, moreover I can’t see any display whenever I starts Jetson. One more thing to add here is that I didn’t have HDMI style monitor so I used HDMI to VGA converter cable to connect Jetson TX2 to monitor. Then I tried HDMI style monitor and it worked fine without any red screen. Is there any way by which I can use my previous VGA compatible monitor with Jetson TX2 again because previously with another piece of TX2 it was working fine?


All modern monitors provide a DDC wire which VGA doesn’t have. That wire carries data the monitor uses to describe itself (the EDID data). Without that wire the older VGA monitors relied an a “driver” disk from the manufacturer to help the system configure; EDID replaced that method. Your VGA results in no method for the driver to configure and all you will get is a default fallback mode (and apparently that mode isn’t compatible with your monitor). The current driver only allows configuration via EDID, so I’m afraid you’ll need an HDMI or DisplayPort monitor (most DVI monitors work too, but not 100%).

In the case where the monitor used to work it would have been because the default mode was something the monitor understood…“you got lucky”.

Being using hdmi - vga I used to get something like described a couple of times, I believe.
Finally I figured out that I can use vga monitors without issue if I connect it to hdmi-vga adapter after the system got booted. But if I connected it before it wont boot.
Thus, support of vga monitors is kind of depreciated, as it seems to me.
And USB-c is not seem to be supported as for now at TX2. But hdmi and dvi monitors should work as linuxdev explained, without issues, as I understand.

Ok, so i had this issue and yes i think it was a simple case of flashing device. For me i quite foolishly didn’t realise i would need to flash the device before being able to use it, and i didn’t realise I could only flash using a Linux machine. And yes, post flash make sure you run the instructions or it will probably just keep happening. The documentation was not very clear around this when i got mine, hopefully its improved now :D

As an aside, for monitors etc you could buy a smallish standalone tablet screen, i was using one and it worked really well for demo purposes.