Jetson TX2 SSH Through Router

Hi everyone,

I have flashed Jetson TX2 with a custom carrier board. I want to place Jetson TX2 in a UAV and stream camera footages from sky. I am using a Rocket M5 and Nanobeam M5 for wirelesss setup. Rocket M5 is linked to TX2, Nanobeam is deployed at groundstation. In theory there would be network between Jetson and groundstation.

I tested this setup with various Raspberry Pi models and I could get live footages from sky. My problem is I cannot SSH to Jetson when it is connected to Rocket M5. But I can SSH via direct Ethernet cable through jetson and host computer.

Here is my setup

Laptop → Nanobeam M5
Nanobeam M5 > Rocket M5
Rocket M5 > Jetson TX2

Any suggestions?
I am sure system is working. I can ssh to raspberry pi via ssh pi@raspberrypi.local. But it does not work for my Jetson connected to Rocket M5.

I cant see ip adress assigned when i type ifconfig.

If we use TX2 developer kit and connect it to host PC through USB type-A to micro-B cable, we can login TX2 by executing the command on host PC:

$ ssh _USER_NAME@

Not sure if this can be applied to your use-case.

Hi DaneLLL,

Thank you for your reply. I know, I can SSH with USB Cable but it is not an option for my use-case. Let me explain my setup more detailed.

There is a fixed wing UAV, in the UAV I have Ubiquiti Rocket M5 module which is connected to Jetson TX2. On the ground I have Ubiquiti Nanobeam M5 module. Practically Rocket and Nanobeam modules are synchronized so that there is network connection in the UAV.

I can connect to the network just linking raspberry pi to the Rocket M5 via ethernet cable and ssh to it by “ssh pi@raspberrypi.local”

But whenever I plug Jetson TX2 to Rocket M5, I can not SSH, by ssh hostname@username.local.

I type ifconfig to TX2 terminal and there is no ip assigned to TX2.
I can SSH TX2 if i link it to my windows PC via ethernet cable by “ssh hostname@username.local”

I have working setup which is proven with Raspberry Pi, but it does not work with Jetson TX2. I think there is a problem with IP assignments

You might want to post the output of these when you are set up to try to run wireless:

rfkill list

Incidentally, sometimes Wi-Fi is tied to whether or not someone is logged in to the GUI. So make sure that if you are testing in text mode, without the GUI, that the output of those commands are also in text mode.

Thanks for your reply.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.