Jetson TX2 stuck at NVIDIA logo and unable to restore factory settings

Existing situation:

  1. Device (Jetson TX2) on power up is stuck at Nvidia logo

  2. Trying to restore the device to factory settings.

  3. Trying to enter recovery mode (by pressing the recovery and reset mode buttons together for 5 seconds when the power is on and later on releasing the reset and holding on to the recovery button for 5 more seconds) and find the device on ubuntu 18.04 machine through lsusb command.

  4. However we are unable to see Nvidia-Corp in the listings of lsusb.

  5. To diagnose why the device was not detected we have done the following:

  6. Checked the USB port on the Ubuntu 18.04 machine.

  7. Checked the micro usb cable used to connect the Ubuntu 18.04 machine wih Jetson TX2.

  8. Tried using another connector board of a working device to see if we could enter the recovery mode.

  9. Repeated process on other USB ports.

We have hence ruled out most-likely extraneous factors preventing us from entering recovery mode.

Procedures attempted to reflash the JetsonTX2:

  1. Downloaded SDK Manager on an ubuntu 18.04 machine (host computer)
  2. Tried Building the image for Jetpack 4.6 (rev3)
  3. We ran into issues with the auto updation of host packages due to SDK Manager and hence could not proceed further. The SDK manager throws the error “Your system is not ready for install, see specific errors below. Once fixed, click ‘Retry’ to verify system readiness again”(The log file is attached below)
    SDKM_logs_JetPack_4.6_(rev._3)_Linux_for_Jetson_TX2_modules_2023-01-18_16-21-14.zip (96.0 KB)

REQUESTING FOR:

An alternate solution to restore factory settings on the Jetson TX2 device.

Hi vishesh,

Are you using the devkit or custom board?

Could you help to capture the serial console log when the board stuck at Nvidia logo for further check?

It means that you enter force recovery mode failed.
Are you using Ubuntu 18.04 with VM or docker? Or the standalone Ubuntu18.04 as your host PC?

It looks the package management system has some broken dependencies on your host system even before the installation starts.