JETSON TX2 system menu and tool bar disappear

I’ve experienced an unexpected cash on Linux system, where the system hotkeys are not functionating and the cursor is turned into a crossing (from an arrow). Besides, the off-buttons of windows are gone and the dock and the toolbar are gone either.

I’m not able to call the terminal to handle any debugging process by far, which is very frustrating. Is there anyone who can solve this problem for me? Of my best appreciation.

this issue is solved using the method below:

use ctrl+alt+F1 , enter your account and passord.

reset the system configuration:

mv ~/.config/compiz-1 ~/.config/compiz-1.old

return to the system:

sudo service lightdm restart

I come up with the same crash again after I flashed TX2 with jetpack 3.3, and reopened it.

The above method doesn’t work this time, but I solved it as such:

sudo rm -r /home/nvidia/.cache/compizconfig-1

To sum up, most of problems related to menu bar and tool bar absense may be caused by the destroyed setting of compizconfig-1,
either in ~./config, or in /home/nvidia/.cache; to solve it, just remove these settings and the system will recover.

Tried your method but didn’t worked for me.
And i am very new to this. Any suggestion would be very helpful.
I am missing my task bar only. Without any crash. Started nano this morning and taskbar was missing. Day before that everything looked fine.