Jetson with realsense and isaac ros


I am using Realsense D435. While I am running its ros wrapper alone the publishing rate is 30 HZ like it should be. then I run deepstream 6 ros node and the publishing rate of a realsense drops to 12 Hz. What is the explanation to that and how to fix that.


Which Jetson and ROS version are you on?
Have you built realsense ros node from source with v4l backend.?

Please let us know.

Hi Thank you for contacting in the session, we can discuss here more and lets try to solve the issue.

Thank you for respond,

My ROS 2 version is foxy. I have build it from this repository GitHub - IntelRealSense/realsense-ros: Intel(R) RealSense(TM) ROS Wrapper for D400 series, SR300 Camera and T265 Tracking Module from my ros workspace. I also tried to run realsense from docker GitHub - NVIDIA-ISAAC-ROS/isaac_ros_visual_slam: Visual odometry package based on hardware-accelerated NVIDIA Elbrus library with world class quality and performance. without the vo I had the same effect.

Could you please send me steps to reproduce your issue?

  • open terminal01: ros2 launch realsense2_camera
    -open terminal02: ros2 topic hz /camera/color/image_raw you will see 25-30hz which is fine by me
  • open terminal03: run another node that uses this topic and you will see slow drop towards 12hz in the terminal02