Jetson Xavier AGX - Persistent 'testkey is used' Warning Message and Booting Issue

Hello NVIDIA community,

I am encountering an issue with my Jetson Xavier AGX board, where despite flashing multiple versions (5.0.2, 5.1.0, 5.1.1), I consistently experience the same problem. During the boot process, a “testkey is used” warning message appears, and if I quickly press Enter, the booting proceeds successfully. However, if I leave it without pressing Enter, the board continuously reboots, displaying the warning message repeatedly.

I have tried flashing different firmware versions in an attempt to resolve the issue, but the problem persists. The warning message seems to be causing interruptions in the booting process and affecting the board’s normal functionality.

I would greatly appreciate any insights or suggestions on how to address this issue. Are there any specific steps or configurations that can be recommended to bypass or resolve the “testkey is used” warning message during boot? I am open to trying any troubleshooting steps or providing additional information as required.

Thank you for your support and assistance in finding a solution to this persistent issue.

please help me


I don’t think your issue is related to those text.

What you need to do here is enabling the uart console and see what happens if you don’t press enter. And also what happens when you press enter.

Honestly, those text on screen totally not matter in my opinion.

1 Like

Alright, I got it. I will retrieve the logs through UART communication and take a look.
Firstly, there is an opinion that the warning message is not related to the inability to boot, right?
However, since I don’t have the board with me at the moment, could you suggest some possible causes?
Sometimes, along with the warning message, it keeps rebooting, but occasionally it boots successfully with the “attempting direct boot” message even when left untouched.

It is not possible to tell possible causes in this situation.

This text is just few print function inside the UEFI bootloader.
After UEFI, it comes linux kernel. And any kind of kernel panic could lead to a reboot.
And any I/O has chance to lead to kernel panic. We need to check your log to tell if this is some known issue or new issue that we need to debug.

So, your log is needed here.

Or you could just remove everything and only leave the power there. And see if you can boot up.

1 Like

Thank you so much.

Let me confirm if I understand the UEFI diagnostic procedure correctly. After connecting the host PC and Jetson using a micro USB cable, I need to set up a minicom session, and then I can check the logs that appear when I boot the Jetson board, is that correct?

  1. micro usb connecting
  2. minicom setup in hostpc
  3. boot jetson and check the log

Yes, dump the log when it fails to boot and also the log when it successfully boots.

I need 2 logs here.

1 Like

okay thank you , i will be back with some logs.
super thaaankyou

since my jetson is connected with other devices, now I can’t use micro B port…
can I connect the jetson and host pc using other port?

Actually, I feel your comment does not make sense.

Are you talking about your jetson’s micro usb port is connecting to other devices? What devices? Are you sure this is NVIDIA devkit? Or you are not sure what does NVIDIA devkit mean?

The micro usb port on Xavier AGX devkit does not have functionality of usb. It is a UART port.
So it is weird that you connect other device on this port.

1 Like

Now the Jetson is embedded deep in my other device, so I can’t reach the port.
Is there other way?
(Micro b port is empty)

No other way. The flash log only comes out from that port.

1 Like

okay… thanks
This is my log.
the Jetson booted after 2 reboot with message, ‘testkey is used’.
fa1.txt (142.5 KB)


Please adjust the size of your terminal and dump your log again.

The log you shared has truncated in each line…

For example,

I only see this in your log. But there are still something after rootfstype= and you didn’t copy that.

[ 0.000000] Kernel command line: root=/dev/mmcblk0p1 rw rootwait rootfstype=

Not just this line. I mean every line.

This is my new log and reboot with message ‘ASSERT [TerminalDxe] /out/nvidia/bootloader/uefi/Jetson_RELEASE/edk2/MdeModulePkg/Universal/Console/TerminalDxe/TerminalConIn.c(2078): ((BOOLEAN)(0==1))’ .

now it does not boot any more. only recovery mode
fa23.txt (70.1 KB)

please …


/out/nvidia/bootloader/uefi/Jetson_RELEASE/edk2/MdeModulePkg/Universal/Console/TerminalDxe/TerminalConIn.c(2078): ((BOOLEAN)(0==1))’

That issue is already resolved in latest jetpack version. Your BSP version is too old. Please upgrade.

what is the BSP version??
I already tried jetpack 5.1.1 but has same issue…

how can i upgrade it??


I have to say that the log you posted didn’t catch any point that we can check…

You only had one line here. I can only tell you this error has been fixed in rel-35.2.1/jetpack5.1.

ASSERT [TerminalDxe] /out/nvidia/bootloader/uefi/Jetson_RELEASE/edk2/MdeModulePkg/Universal/Console/TerminalDxe/TerminalConIn.c(2078): ((BOOLEAN)(0==1))

And the next boot goes into recovery image. That log does not help. Also, each of line still got truncated.

I need to ask you something else

  1. Are you using NV devkit or custom board?

  2. Are you booting from external drive or emmc?

1.I use jetson xavier agx board
2. boot from emmc