Jetson Xavier AGX with SJA1105ELY


I have designed a custom Jetson Xavier AGX with the SJA1105ELY and the original PHY 88E1512-A0-NNP2I000. My questions are:

  1. There is an in-kernel driver for the SJA1105 (document and source code). Does any of the Jetpack versions support this driver? If not, is there a way to obtain it?
  2. Because the PHY is taken from the reference carrier board design, I assume there should be minimal configurations needed. With the MDIO tool, I tried to modify the RGMII voltage level to 2.5V (page 2, register 24) and the MODE (page 18, register 20) to RGMII.
    Is there anything else I need to configure for the PHY?

Sorry for the late reply, have you find the answer to remove the concerns?
Any result can be shared?


Hi kayccc,

Yes, finally I solved the issue.

  1. I don’t think there is an in-kernel driver for now as it only starts from kernel 5.2.
  2. Apparently at the end we need to reboot the board to restart the necessary network services. While I believe we could start them with a command line or script, I just did not have the chance to write one. sudo reboot works for me.

Glad to know it’s resolved, thanks for the update!

Hi, geraldus_mikael
When you remove the original PHY 88E1512, how do you change software?
Because eqos_open returns false due to eqos_init_phy error, network cannot successfully setup.

Hi @ycl,

Sorry for the late reply. For some reason your response went to my junk folder.

I never removed the original PHY, thus I’m not sure about the answer to your problem. Also, I don’t have access to this project anymore since I switched jobs.

Hi Mikael,

I am design similar design, could you help ? I am not sure option 1 or option 2.
Many thanks.