Jetson Xavier & ECUSim-2000 CAN communication error

Hello Everyone.
I want to ask you guys about the problem now I’s experiencing.

I was trying to use CAN communication in Jetson Xavier and testing with ECUSim-2000.
I succeeded the CAN loopback test in Jetson Xavier before. And I tried to use CAN communication in Jetson Xavier with ECUSim-2000. I’m using Wireshark to capture sended CAN data.

When I try this, Wireshark capture the data, but the Rx data didn’t appear in Terminal below ‘candump can0’.
Is it means that CAN is not working in this module?

I tried to find the information about this problem, but there is not enough information. So I want to ask everyone if there’s anyone to solve my problem.

This is the screen now I see.


Hi 2020130022,

Are you using the devkit or custom board?
What’s you Jetpack version in use?

Is that the CAN transceiver? How do you configure that and enable CAN?

KevinFFF, Thanks for replying.

I forgot the information about it. ECUSim is the CAN simulator. I connected CJMCU-230(CAN Transceiver) with Jetson AGX Xavier. I connected CJMCU-230 and Jetson AGX Xavier by googling.

I am using Jetson AGX Xavier Developer Kit. I want to make candump can0 to recieve the CAN data and appear in the terminal. But it didn’t work. That’s my situation now.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Could you share the block diagram for your connection for CAN transmission?
and also every commands you used to configure and setup the can bus.