Jetson Xavier keeps reboot.

Dear All,

My Jetson Xavier keeps reboot forever. It never goes to the login screen.

Is this a hardware problem or corrupted image?


Hi dtyu,

Not sure what you’ve done before, any device connected with devkits?
Please reflash the image with JetPack again to see if can recover.


I added a 10Gbps card on PCI-Gen 16 lane. It worked and I can do 10Gpbs data transfer with another service. But I left the Jetson Xavier unattended for a week. it went to this weird state even I unplugged the card.

I will reflash it. it is pain because I can not save the image and have to deploy the whole thing again!

I’ve seen similar behavior when the root filesystem is full.

How did you fix it except reimaging the device? I do not have a backup for the box and have to redeploy all packages. Does NVIDIA Jetson provide an option to boot into a single user?

I was able to ssh into the Xavier machine and delete the log files (/var/log/).

How did you ssh into the box? The Jetson does non-stop rebooting. sshd did not even start. Do you put it into force recovery mode?

Do you use the usb cable to connect to the Xavier?

I sshed in via Ethernet. I guess my case was not the same as yours because sshd was running. It was only X that wasn’t starting.

Serial console will always be logged in to user “nvidia”. So long as that user can delete files it might be able to work for you. Depends on if tmp files need to be used (and I think sudo needs a tmp file, so you probably can’t use sudo). On the other hand, if it keeps rebooting, it won’t help.

I noticed Kernel crash in the Jetson Xavier. I had to reimage the box. now it is OK>

So I think the issue is the SD card, I was experiencing the same problem with a 128GB SD and the system kept rebooting and being slow, I tried reimaging the SD card and same behavior. I tried using a much smaller SD card (32GB) and the jetson boots up fine and so much faster, no reboots.