Jetson Xavier Kit + SSD break internal audio card driver

Internal audio card did not work when I insert any SSD M2 to Jetson Xavier Kit.
Without SSD I can use internal audio from J511.
This happen on 4 different Jetson Xavier Kit devices with 2 different SSD.

dmesg
[ 2.424856] rt5659 7-001a: Device with ID register ffffff80 is not rt5659
[ 2.512628] OPE platform probe
[ 2.512735] OPE platform probe successful
[ 2.524842] tegra-asoc: sound: ASoC: CODEC DAI rt5659-aif1 not registered
[ 2.524895] tegra-asoc: sound: snd_soc_register_card failed (-517)

I think the issue here seems to be with the I2C lanes where the SSD being connected is misbehaving withe the I2C bus. Since it is the same I2C bus which is coming to both the M.2 slot and the audio device, nothing much can be done from SW. Please try to put a tape on the I2C lanes of your SSD so that they don’t make any electrical contact with the I2C lanes of M.2 slot (Since the I2C lanes of an SSD aren’t typically used , this shouldn’t create any other problem)

I insert SSD to Jetson M2 Key M slot [J1].
As I can find in spec Key M did not have any I2C lines in pinout.
So my guess is that the Jetson does not have a Key M slot, but a wider one?

Could you please provide the pins that I should isolate on the SSD?

Pin40 and 42 are I2C_GP4_CLK and I2C_GP4_DAT

Thank you so much!
The method actually worked and the sound card worked again.
But it is very difficult to glue izsolette like that :)

1 Like