Jetson Xavier NX booting to bash

Hi guy
Please I need a help.When I bought my Jetson Xavier nx, I flashed it with jetpack 4.5.1 on it and everything was working perfectly fine. I tried to install imx477 CSI camera driver on it ,but the installation failed. Everything worked fine that day , I rebooted the system several times that same day and it was still working fine. The next day when I try starting my Jetson nx its now booting to bash . i have tried several SD cards but it still giving same issues, I even tried the same SD cards on my Jetson nano its working perfectly fine.the image is shown below…please I seriously need help.

hello adebolajos,

IMX477 did not enabled with JetPack-4.5.1 release; could you please moving to the latest release, for example, JetPack-4.6,
you could also check release note, Release Notes :: NVIDIA JetPack Documentation
it’s supported to configure via Jetson-IO tool to enable IMX477 at run time.
thanks

Okk thanks I saw that on the reviewed i. The current jetpack flashed on my SD card is 4.6 I thought it would help in solving my boot problem .but still showing same result

hello adebolajos,

did you mean you fully flash Xavier NX with JetPack-4.6, and you still cannot enable Raspberry-PI High Def, IMX477?
could you please share your steps for reference, thanks

Its not even about the CSI camera the system is booting to bash.the screen image is shown above on my first Post.

I used the steps from the nvidia official site…

could you please install JetPack-4.6 through NVIDIA SDK Manager | NVIDIA Developer?

The SDK manager is not recognising my Jetson NX …but my Jetson nano is recognised by the SDK manager

hello adebolajos,

had you try disconnect power-supply, leave it for a short while, then press recovery button and power-on the board?

JerryChang thanks
Let me try it and see right away

Hello jerryChang
This is the error am getting when using SDK manger


Your error is similar to his case. It looks like you modified the eeprom of the module through i2c tool before and you didn’t notice.

I am also wondering why you are booting into bash. Can you also dump the log?

Log file with empty SDcardserialdebug.txt (2.2 KB)

This looks not even able to boot into bash. Is this the same device as your first comment?

Yesss

Its not even booting to bash again. Even when I connect the HDMI cable is not showing anything on the display monitor

Hello wayneWWW
I don’t even know what to do again.

Hi,

Please provide this info in flash.sh and see if it can bypass the check for eeprom.

sudo BOARDID=3668 BOARDSKU=0000 FAB=100 ./flash.sh jetson-xavier-nx-devkit mmcblk0p1

Hi wayneWWW
thank you for your support where do I locate the flash.sh file ??