Jetson xavier nx boots into lxde automatically

My installation of network manager became corrupt so i installed it by downloading it to a usb drive

network-manager-gnome
network-manager
Using sudo dpkg -i *.deb

However, now whenever i turn on the jetson it uses lxde instead of the defualt.

Is there a way to return it to the default?

Sorry for the late response, have you tried to reflash the device to see if it works?

Please check.

I was unsuccessful in resintalling the default desktop, and ended up reflashing the drive and reinstalling everhthing